Jump to content
Corsair Community

Vengeance RGB Pro Hardware Effect Reset on Wake


cmcguffin
 Share

Recommended Posts

I'm seeing an issue wherein the hardware lighting effect configured for my Vengeance RGB Pro is being reset to a default "rainbow" effect after wake from sleep. Here's how to repro:

 

In iCue -> Settings -> Vengeance RGB Pro, ensure that "Enable full software control" is unselected.

 

Initialize Vengeance RGB Pro profile with e.g. Static effect.

 

In iCue -> Settings, Vengeance RGB Pro, select "Enable full software control".

 

Add e.g. Lighting Link Color Wave effect to Vengenance RGB Pro (and other devices).

 

Put machine to sleep. As machine is put to sleep, and during sleep, Vengeance RGB Pro uses hardware effect (e.g. Static), as expected.

 

Wake up machine. Before logging in, Vengeance RGB pro uses default rainbow hardware effect. After logging in, iCue applies software effect, as expected.

 

Put machine to sleep. When asleep, Vengeance RGB Pro uses rainbow hardware effect. After waking machine and logging in, software effect is used as expected.

 

Is there a trick to ensure that the hardware effect does not fall back to using the default? Thanks!

Link to comment
Share on other sites

Thanks -- that procedure resets it once, but after the next sleep cycle, the rainbow is back. I'm hoping to avoid fiddling with iCue after every sleep cycle. :)

 

To be clear, the lighting effect listed in iCue don't change. It's as if the specified HW effect isn't being applied after the first wake from sleep.

Link to comment
Share on other sites

They'll have to look at that and see if they can reproduce the bug. However in the short term, if you are using any of the predefined or Lighting Link effects, you may be better off taking the RAM out of software controlled mode and setting Lighting Link ____. This will apply to hardware mode. I am using HW mode only and I am not seeing any issues on wake. The RAM of course will continue to flash while napping unless you select Instant Lighting Black or something similar prior to putting it to sleep. Software RAM mode uses a decent amount of resources, so unless you are utilizing multiple overlay lighting effects, it may not be giving you anything back.
Link to comment
Share on other sites

Ah, indeed, turning off SW control and removing the static effect does work better. The Lighting Link effect is applied during repeated sleep cycles, though the default rainbow effect is still visible after wakeup but before login. I can live with that.

 

I wish I could use different effect when in sleep, but I can also live with the Lighting Link effect.

 

Many thanks!

Link to comment
Share on other sites

I don't think there is any getting around the Windows "signed out" rainbow debacle... at least not without modifying Windows. I think there are a few threads kicking around (key word "lock screen"), but since I never log out on my home computer with all this stuff I don't pay much attention to it.

 

You can apply a second effect in hardware mode on top of the Lighting Link that will cover over. Don't delete the Link effect or it drops from all devices. However, that is getting to be a bit tedious unless it going to be in sleep mode for a while. There is also a slight lag effect when applying any hardware mode effect as it is written to the device.

Link to comment
Share on other sites

 Share

×
×
  • Create New...