Jump to content
Corsair Community

iCue does not recognize devices after Windows 10 Update


MagoKimbra
 Share

Recommended Posts

I have iCue with corsair peripherals for a long time, and everything worked properly.

Some days ago there was a Windows 10 patch from then on when I turn on the PC, icue does not recognize the USB devices, Keyboard (K95 RGB), mause (Glaive RGB), Pad (MM800 RGB), commander pro. The software starts, but nothing is driven, the peripherals work, but with standard lighting. I have to close iCue and start it again at that point everything goes back to working.

It is updated to the latest version, also tried to uninstall Icue and reinstall it, but it does exactly the same.

There is also another software, for asus Phoebus, that asks me for permission to use it when it is turned on. As if for some software the administrator authorization was lost, at least I think ... But I can't get out of it in any way. Can you help me?

Link to comment
Share on other sites

It is my believe that windows is fuXXXXX it up. I have also isues with several lightnings… (and icue fans)… Three days ago my infinity mirror (MSI motherboard x570 ACE froze … Yesterday another update (security update) of windows and it started working again… Today only one of my fans (680x case) in ICUE works anymore… (in ICUE soft three fans are working, but not in real life... So only one fan …) : My two cents : microsoft is messing everything up again (as usual).
Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...