Jump to content
Corsair Community

Corsair Virtuoso wont charge or turn on


antlun
 Share

Recommended Posts

Hello,

 

Ive only had the headset for about 24 hours and now it's completly dead, it wont charge or connect to the computer at all.

 

Worked fine yesterday... Anyone else having the same issue? The audio crackled alot in games yesterday also.

 

200 euros for a headset that died within this few hours is not good :(

Link to comment
Share on other sites

Hello, I had the same issue. Except mine was charging before a gaming session began. I never let the headset die.. Come back hours later corsair headset appears dead( no lights or sound or detected in my software). Unable to turn it on to have it work with the computer. ICUE says headset is not available.. why did I pay this much for a headset that doesn't even have an on off switch? Just a usb to wifi switch? Seems like you guys should have installed an off switch not a manually turn off after x amount of hours or whatever you did corsair... How are my void pros already a better headset in terms of functionality when they don't come close to the price of the new headset? I did leave it charging(cable works tested my phone on it and the phone was charging) nothing works tried using different cable like above post suggested. Still didnt come back on. I returned the headset.. Guess I will gamble with the Astros next. Return your headset if you can't get it to work. Good luck though.
Link to comment
Share on other sites

So I just ran into this issue and got mine to start working again

 

-Got the latest ICUE software

-Plugged them in via USB C

-Plugged the Mic in (if it isn't already.)

-Kept the dongle plugged in

-Noticed that the Headsets had the Unavailable icon

-I then pressed the Mute button and flicked the Wireless/USB switch back and forth about 5 times. Then they turned back on.

 

This worked for me and I hope it works for you all.

Link to comment
Share on other sites

So, I had the same issue with my headset and apparently the power from a computer USB isn't enough to charge the headset. You must use a separate power source like a phone charger to power them. I'm not sure how corsair is going to handle this on their end but it kinda sucks you can't charge them on a computer.

 

So for people having the same issue, plug them into a phone charging brick / wall wart to charge them for about 10-15 mins then they should come back on.

Link to comment
Share on other sites

  • Corsair Employees
If you keep the headset plugged in to the USB cable and your system turns off or goes to sleep the headset will recognize that it is plugged in and keep attempting to establish a charge connection but the USB port isn't providing any power. When this happens the headset will die. To fix this unplug the headset and turn the system on. Then make sure the headset is set to wired mode and plug it in to charge. Leave it for 15 minutes then unplug it and turn it back in to wireless. This should resolve the issue.
Link to comment
Share on other sites

Hey guys, my headset just did the same thing wouldn’t turn on. I left it on wireless mode (because it auto shuts off after 10 min) and put my computer to sleep so I thought maybe the battery died but just wouldn’t charge or turn on. What fixed it for me was downloading the latest firmware then it just turned on instantly. Hope that helps for some of you!
Link to comment
Share on other sites

  • Corsair Employees
Hey guys, my headset just did the same thing wouldn’t turn on. I left it on wireless mode (because it auto shuts off after 10 min) and put my computer to sleep so I thought maybe the battery died but just wouldn’t charge or turn on. What fixed it for me was downloading the latest firmware then it just turned on instantly. Hope that helps for some of you!

 

Yes the latest firmware update fixes this problem.

Link to comment
Share on other sites

Yes the latest firmware update fixes this problem.

 

If the headset is not plugged into USB port but it is in USB mode (to power it off) will it still drain the battery or is this the correct method to switch off the headset?

Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...
  • 3 weeks later...

This is super frustrating. My virtuoso constantly "forgets" it's charged. Once it's in that state, it will never connect in wireless, no matter how long I charge it.

 

It does seem like updating the firmware does solve the issue temporarily. So if you're having this issue, connect your virtuoso with the cable, and then try going into icue, go to settings, and click the update firmware button for your virtuoso. Make sure you don't disconnect it during the upgrade and upgrade it even if you already have the most current version. It will temporarily solve the issue, at least for me. Maybe just repairing might solve it as well? Can't really test it right now, since it's working at the moment.

Link to comment
Share on other sites

  • 1 month later...
This is super frustrating. My virtuoso constantly "forgets" it's charged. Once it's in that state, it will never connect in wireless, no matter how long I charge it.

 

It does seem like updating the firmware does solve the issue temporarily. So if you're having this issue, connect your virtuoso with the cable, and then try going into icue, go to settings, and click the update firmware button for your virtuoso. Make sure you don't disconnect it during the upgrade and upgrade it even if you already have the most current version. It will temporarily solve the issue, at least for me. Maybe just repairing might solve it as well? Can't really test it right now, since it's working at the moment.

 

I'm having the same issue. I plug the headset in overnight to a powered USB port so it is charging. Days will go by and it works fine wirelessly and then all of a sudden I will take the headset off, go and do something, come back and it's flashing red and won't connect. If I plug the USB in it will, but as soon as I switch to wireless mode it won't work.

Like you said forcing a firmware re-update seems to fix it for a short time. It's also sudden;y showing up in iCue as the Virtuoso SE (1) (1) (1) (1) (1), etc....lots of (1)

Link to comment
Share on other sites

I'm having the same issue. I plug the headset in overnight to a powered USB port so it is charging. Days will go by and it works fine wirelessly and then all of a sudden I will take the headset off, go and do something, come back and it's flashing red and won't connect. If I plug the USB in it will, but as soon as I switch to wireless mode it won't work.

Like you said forcing a firmware re-update seems to fix it for a short time. It's also sudden;y showing up in iCue as the Virtuoso SE (1) (1) (1) (1) (1), etc....lots of (1)

 

EXACT same issue here! Was working fine since March when I got it. Now it wont charge at all. ive tried everything listed here with no luck. And what is with all the (1) showing now???

Link to comment
Share on other sites

In the past week it's happened twice. I had the headset plugged in and charging overnight and this morning it will not connect in wireless mode at all. I'm about to uninstall the whole thing and start over. This is super frustrating, especially as I bought this specifically for work.
Link to comment
Share on other sites

  • 5 months later...
 Share

×
×
  • Create New...