Jump to content
Corsair Community

K57 RGB Firmware Issues


Frazzz
 Share

Recommended Posts

Hi folks!

 

So I'm at a loss of what to do with this now, the windows lock key, scoll lock and caps lock key all flash. And the ICUE software detects the keyboard but has a big red button next to its status/battery (its plugged in via USB cable). I cannot get the flashing to stop adn the RGB to come back.

 

Firmware update on ICUE for the keyboard constantly seems to "fail".

 

I've tried different USB ports (3.0 and 2.0) Front and back.

Tried the FN + F5 & Escape Key hold in and the FM + F4.

I've tried resetting it (located under the right stand up foot) which infact needs a replacement firmware that I cannot seem to locate.

Reinstalled EVERYTHING from the ICUE software, drivers.

Made sure USB power wasn't shutting off.

Uninstalled and reinstalled those drivers too.

Tried it in another completely different PC and it still keeps doing it.

 

Hope someone can help with this...

 

Thanks

 

Fraser

Link to comment
Share on other sites

  • Corsair Employees

Hi,

 

We recommend performing a clean install of iCUE. Please follow the steps below:

 

Open your computer's Control Panel.

Open the Programs and Features options.

Select Corsair Utility Engine in the list, and then select Uninstall.

Open your Start menu and type "Run". Then open the Run option.

Type Regedit and then click OK.

Navigate to HKEY_CURRENT_USER\Software\Corsair\Corsair Utility Engine

Right-click and delete the folder.

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Corsair\Corsair Utility Engine

Right-click and delete the folder.

Restart your computer.

Download a new installer file for iCUE from Corsair.com and reinstall.

 

 

If you need assistance with these steps, please reach out to our support team by creating a ticket. Here's is the link:

 

help.corsair.com/hc/en-us/requests/new

Link to comment
Share on other sites

Hi there and thank you for getting back to me, sadly I done all this and still the keyboard is just sitting flashing I've attached an image of the ICUE software of how its showing the keyboard.

 

It just keeps failing the firmware. So I'd think I'd need this, I opened a ticket 2 days ago and yet to hear back still.

 

Anytime I hit update, it disappears then errors.

 

Thanks

97829963_ICUEsoftwareimage.thumb.png.39ee9d6fd69f618d28a000683853ef96.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...