Jump to content
Corsair Community

Corsair Virtuoso RGB Wireless SE feedback


Recommended Posts

Hello,

 

In my case a problem appears with playerunknown battleground, the volume increases a few seconds after the jump from the plane. Then once on ground the volume drops, as soon as I do not move the sound increases and as soon as I run it decreases.

 

I think that the headset try to amplify the sounds close to me while I would like to hear those who are far off, I check in windows but no option of this type is activated

Link to comment
Share on other sites

I'm gunna drop my feedback here for the Microphone:

 

 

Microphone quality is quite poor and muffled, it's nowhere close to the clarity on other, much flimsier detachable microphones I've used such as the HyperX mics. We need more microphone options to adjust this, as it sounds like I've got a constant item muffling my speech, or like I'm talking into a cheap Walmart earpiece even though it's supposed to be enthusiast level gear.

Link to comment
Share on other sites

Hi , this is my feedback

Bought the headset a few days ago.

I must say that I really like the headset , sharp look , sounds good mic is ok ect..

But mine deliver more sound on the left side than the right one.. It's really subtle but I'm sensitive to this , I've no other choice to return it...

Link to comment
Share on other sites

Hi , this is my feedback

Bought the headset a few days ago.

I must say that I really like the headset , sharp look , sounds good mic is ok ect..

But mine deliver more sound on the left side than the right one.. It's really subtle but I'm sensitive to this , I've no other choice to return it...

 

Could be an hardware failure. Perhaps contacting Corsair support to get it exchange?

Link to comment
Share on other sites

Could be an hardware failure. Perhaps contacting Corsair support to get it exchange?

 

Yea it must be that..

Already done :)

I Just hope they will confirm what I am saying because I got the headset tested by somes friends and they are divided lol , most of them told me that they can barely hear the problem and a few other told me they had found a balance problem without me mentioning it..

Wait and see :laughing:

Link to comment
Share on other sites

Yea it must be that..

Already done :)

I Just hope they will confirm what I am saying because I got the headset tested by somes friends and they are divided lol , most of them told me that they can barely hear the problem and a few other told me they had found a balance problem without me mentioning it..

Wait and see :laughing:

 

Good luck then! I am sure Corsair will help on resolving the issue.

Link to comment
Share on other sites

I've spotted a couple issues which I'm not sure can be fixed due to the functionality of windows 10.

 

Firstly, there are two times this issue occurs:

 

1) When switching from USB to Wireless (or visa Versa).

2) When the headset auto turns off (maybe this is just me, if I'm deep into a game and 10 minutes pass without me moving my head much, the headset assumes I'm AFK and switches off).

 

What happens when either of the above occurs is Windows 10 assumes you've lost sound briefly. This causes discord and any game I'm playing (tested so far with overwatch/destiny2/minion masters) to stop working.

I've noticed this issue before in discord on another headset when I switched to Dolby atmos. It seems that whatever discord registered on initial startup, if that's changed, then discord just stops working altogether and you need to restart the software.

The same happens during a game. Sound will just stop altogether and in most cases, I need to fully reboot my PC to get sound back.

 

The simple fix so far is to make sure I don't switch between USB / Wireless unless I'm out of discord or a game.

 

The other fix is to turn off the 'auto switch-off' function or increase the timer to 60+ mins and remember to switch the headset to 'USB mode' when I've finished so it doesn't stay powered on and drain the battery.

 

These aren't major issues, but it can be frustrating at times.

Edited by rik182
Link to comment
Share on other sites

I've spotted a couple issues which I'm not sure can be fixed due to the functionality of windows 10.

 

Firstly, there are two times this issue occurs:

 

1) When switching from USB to Wireless (or visa Versa).

2) When the headset auto turns off (maybe this is just me, if I'm deep into a game and 10 minutes pass without me moving my head much, the headset assumes I'm AFK and switches off).

 

What happens when either of the above occurs is Windows 10 assumes you've lost sound briefly. This causes discord and any game I'm playing (tested so far with overwatch/destiny2/minion masters) to stop working.

I've noticed this issue before in discord on another headset when I switched to Dolby atmos. It seems that whatever discord registered on initial startup, if that's changed, then discord just stops working altogether and you need to restart the software.

The same happens during a game. Sound will just stop altogether and in most cases, I need to fully reboot my PC to get sound back.

 

The simple fix so far is to make sure I don't switch between USB / Wireless unless I'm out of discord or a game.

 

The other fix is to turn off the 'auto switch-off' function or increase the timer to 60+ mins and remember to switch the headset to 'USB mode' when I've finished so it doesn't stay powered on and drain the battery.

 

These aren't major issues, but it can be frustrating at times.

 

Multiple users are also experiencing this. The standby feature of the headset also causes this.

When I take the headset out of standby (with mic muted) > join teamspeak > unmute mic = microphone still not working. I need to restart teamspeak for that.

Link to comment
Share on other sites

Added one more issue found:

- When the headset is off with a different output chosen and you turn on the headset again; the microphone volume is lowered to 70% instead of staying on 100%. Also, it occurs that the volume from the previous output is chosen.

- If the headset is taking out of standby with the microphone muted and you join Teamspeak (only tested Teamspeak) and you enable the mic > Teamspeak needs to be restarted for the microphone to work.

 

Cleaned up some old feedback which resolved by itself and no further reports.

Edited by jpdsc
Link to comment
Share on other sites

Not issues but features:

- ability to set custom RGB lighting on microphone LED (it is there but only available when headset is not connected to PC)

- ability to turn off battery charging on USB Cable via iCUE when headset have communication with iCUE. When not connected to iCUE (due system shutdown e.g.) it should charge it anyway.

Link to comment
Share on other sites

Seriously i cannot believe this audio crackling, popping, random volume levels issues with these virtuosos were not picked up in the testing phase? Really corsair? just try a few games as people have suggested here, it's a mess right now and would rather go back to my old Creative tactic 3d wrath, They've already come out with a new firmware that does jack, and a new i cue today that does not resolve these issues, Guys is this the norm for Corsair ?
Link to comment
Share on other sites

I've spotted a couple issues which I'm not sure can be fixed due to the functionality of windows 10.

 

Firstly, there are two times this issue occurs:

 

1) When switching from USB to Wireless (or visa Versa).

2) When the headset auto turns off (maybe this is just me, if I'm deep into a game and 10 minutes pass without me moving my head much, the headset assumes I'm AFK and switches off).

 

What happens when either of the above occurs is Windows 10 assumes you've lost sound briefly. This causes discord and any game I'm playing (tested so far with overwatch/destiny2/minion masters) to stop working.

I've noticed this issue before in discord on another headset when I switched to Dolby atmos. It seems that whatever discord registered on initial startup, if that's changed, then discord just stops working altogether and you need to restart the software.

The same happens during a game. Sound will just stop altogether and in most cases, I need to fully reboot my PC to get sound back.

 

The simple fix so far is to make sure I don't switch between USB / Wireless unless I'm out of discord or a game.

 

The other fix is to turn off the 'auto switch-off' function or increase the timer to 60+ mins and remember to switch the headset to 'USB mode' when I've finished so it doesn't stay powered on and drain the battery.

 

These aren't major issues, but it can be frustrating at times.

 

I'm having the same issue. I think they should fix the headset where if there is sound, the headset should not go into sleep mode and they also should have the headset get virtual surround sound through windows and not ICUE. I think by not having a power button on the headset made the headset more complicated than what it should have been or at least make it to where you can turn off the headset through ICUE.

Edited by RGBuild
Link to comment
Share on other sites

First: THX for implementing the "LED deactivated while enabled" function within the latest software update! Much appreciated!

Over that it would be great to have the contrary option like at studios:

deactivate the mic´s light when it is DISABLED and switch on the red light when it is on air - just a thought :)

The headset could be somewhat louder at max - but its ok as it is.

Sound is flat (meant to be neutral?!) - but can be adjusted.

My favourite EQ settings are attached - feel free to use it as a start suggest of mine?!

Other issues are already mentioned above....

Beneath, my headset is not crackling - provides a detailed sound experience!

So far worth the money...

 

Regards

 

Settings:

anmerkung2019-10-1915rlkvp.jpg

Link to comment
Share on other sites

Unfortunately I have to report extreme buyer's remorse over the audio quality when using the Corsair drivers in iCUE. I am hoping these are teething issues as an early adopter, but I wish I had waited to buy into this product as it frustrates me to own such an expensive headset which is presently a paperweight. I don't want to stop using the rest of the RGB devices I own from Corsair as a sacrifice to keep being able to hear.

 

My initial impression was good, build quality was excellent, comfort was excellent and it sounded very impressive with the in-store audio samples. I was not looking to buy a new headset and am normally very frugal, so this sold me unexpectedly. Thumbs up there. Unboxing, also great. (Virtuoso SE bag is fun but kind of pointless).

 

I bought these on a lunch break at work, and I tried them on the work PC both wirelessly and wired. Audio was crisp, clear and lovely, no hiss. (Note, work PC does not have iCUE).

 

I tried these on my primary gaming PC when I got back and things started to go downhill. I had an older version of iCUE on that didn't recognise the headset, so when plugged in they used Windows 10 default driver and control, everything still sounded good. I updated iCUE and here things dropped from a user interface perspective, iCUE did not like the headset, and pairing was frustratingly inconsistent. At this point it installed its own drivers and the issue with 2.1 or 8.1 channel came up. Eventually I got that sorted by repeatedly uninstalling and reinstalling the drivers. I applied the firmware patch and this also caused some issues, crashing mid install of the dongle update and showing no progress, with a concerning message about how interrupting may cause corruption - but, nothing to do when it crashes itself mid way through!

 

I am lucky enough to have just upgraded my system, so I had a second PC to try this on for round 2. Fresh install of Windows 10, iCUE not yet installed. Same problem, everything sounded and worked quite seamlessly when not using iCUE, but all the same problems emerged once it was installed.

 

To summarize the actual symptoms that made me take these off and go back to my $50 no name gaming headset (Note, these were observed on 2 separate machines, ranked least to most troubling):

 

  • Bass is kinda weak even with equalization, audio is frustratingly quiet even at max.
  • 7.1 audio sounds like a swimming pool and I can't use Dolby processing as an alternative without uninstalling iCUE.
  • Device failing to recognize when on wireless and losing iCUE pairing to adjust settings. (This has gotten better).
  • Windows would initially would only recognize headset as 2 channel audio.
  • Constant background hiss whenever audio is playing (USB & Wireless)*
  • Cracks and pops, distorted audio in Apex Legends that makes me disoriented. This is what made me take them off and set them down to await some improvement in drivers, it made the game unplayable. I play a lot of Apex.

 

* I don't think this one is mentioned elsewhere in the thread.

 

But in hope of things improving - everything sounded great when initially plugged into my PC. Everything seemed to go wrong with iCUE and the firmware patches.

 

tl;dr - I wish I had read the reviews here and waited a little, right now I don't feel the headset is usable and I'm wondering if this will be addressed or if I should return them.

Link to comment
Share on other sites

Unfortunately I have to report extreme buyer's remorse over the audio quality when using the Corsair drivers in iCUE. I am hoping these are teething issues as an early adopter, but I wish I had waited to buy into this product as it frustrates me to own such an expensive headset which is presently a paperweight. I don't want to stop using the rest of the RGB devices I own from Corsair as a sacrifice to keep being able to hear.

 

My initial impression was good, build quality was excellent, comfort was excellent and it sounded very impressive with the in-store audio samples. I was not looking to buy a new headset and am normally very frugal, so this sold me unexpectedly. Thumbs up there. Unboxing, also great. (Virtuoso SE bag is fun but kind of pointless).

 

I bought these on a lunch break at work, and I tried them on the work PC both wirelessly and wired. Audio was crisp, clear and lovely, no hiss. (Note, work PC does not have iCUE).

 

I tried these on my primary gaming PC when I got back and things started to go downhill. I had an older version of iCUE on that didn't recognise the headset, so when plugged in they used Windows 10 default driver and control, everything still sounded good. I updated iCUE and here things dropped from a user interface perspective, iCUE did not like the headset, and pairing was frustratingly inconsistent. At this point it installed its own drivers and the issue with 2.1 or 8.1 channel came up. Eventually I got that sorted by repeatedly uninstalling and reinstalling the drivers. I applied the firmware patch and this also caused some issues, crashing mid install of the dongle update and showing no progress, with a concerning message about how interrupting may cause corruption - but, nothing to do when it crashes itself mid way through!

 

I am lucky enough to have just upgraded my system, so I had a second PC to try this on for round 2. Fresh install of Windows 10, iCUE not yet installed. Same problem, everything sounded and worked quite seamlessly when not using iCUE, but all the same problems emerged once it was installed.

 

To summarize the actual symptoms that made me take these off and go back to my $50 no name gaming headset (Note, these were observed on 2 separate machines, ranked least to most troubling):

 

  • Bass is kinda weak even with equalization, audio is frustratingly quiet even at max.
  • 7.1 audio sounds like a swimming pool and I can't use Dolby processing as an alternative without uninstalling iCUE.
  • Device failing to recognize when on wireless and losing iCUE pairing to adjust settings. (This has gotten better).
  • Windows would initially would only recognize headset as 2 channel audio.
  • Constant background hiss whenever audio is playing (USB & Wireless)*
  • Cracks and pops, distorted audio in Apex Legends that makes me disoriented. This is what made me take them off and set them down to await some improvement in drivers, it made the game unplayable. I play a lot of Apex.

 

* I don't think this one is mentioned elsewhere in the thread.

 

But in hope of things improving - everything sounded great when initially plugged into my PC. Everything seemed to go wrong with iCUE and the firmware patches.

 

tl;dr - I wish I had read the reviews here and waited a little, right now I don't feel the headset is usable and I'm wondering if this will be addressed or if I should return them.

just uninstall corsair virtuoso in device manager restart pc and it uses legacy drivers. there you go with dolby atmos :) someone on this forum found out. it works perfect

Link to comment
Share on other sites

just uninstall corsair virtuoso in device manager restart pc and it uses legacy drivers. there you go with dolby atmos :) someone on this forum found out. it works perfect

 

No it does not do this if you have icue installed, it just reverts back to the corsair driver and if you uninstall icue tou lose functionality.

 

Also i see theres still no response from corsair for over a week, Don't have long left now before i have to return this partially working headset.

Link to comment
Share on other sites

Is my Virtuoso supposed to remain on while my system is off and is wired. My computer is next to my bed and I exclusively use my Virutoso wired... but it gives off this white light when my system is off. I have to unplug it to get the light off. I've tried doing sleep mode settings but didn't do anything.

 

Wondering if there is a setting i'm supposed to have ticked on or if this is proper and I should be unplugging it every night.

Link to comment
Share on other sites

Right I've come to the conclusion it's Corsairs audio drivers are causing all my issues with audio skipping, breaking up, crackling, missing sounds in games, if i use Microsoft's default USB audio driver ie uninstalling icue altogether the audio is fine, no breaking up when sounds change in games etc, shame on you Corsair, fancy releasing a headset in this state without a single driver update for the headset, does anyone know how can still use the Microsoft driver but still have icue installed for functionality like voice prompts and turning the rgb off etc? I need icue for my h150 i pro.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...