Jump to content
Corsair Community

Games/Computer Lags When Mouse Moves Fix (Polling Rate)


Veralius
 Share

Recommended Posts

This post is for people having the problem of game/computer lag when moving their mouse. My problem was in certain games and very noticeable in file explorer.

 

When I finally upgraded my computer to an i9 9900k CPU and RTX 2070 GPU I was shocked to find my computer lag when running my game at little to no frame rate when my mouse was moving (I use the Scimitar RGB). I started by closing applications to see if there was an issue with one of them and I figured out it was an iCue problem. After more digging I found out it has to do with the polling rate option in iCue.

 

After reducing it from the 1000hz/1ms to the minimum my games were playable but still some hitching. However, my issue of a slow file explorer still continued and would only fully go away if I completely closed iCue. My way less powerful computer (i7 7700k and GTX 970) ran no problem despite the same polling rate. I could tell it was a huge problem because the graphics previewer in the Nvidia control panel would come to a complete stop when I ran my mouse back and forth on it at 1000hz/1ms polling rate.

 

I did some digging and I have finally found the fix to my problem from a hint on another forum. The problem seems to be a polling rate compatibility? problem with the Z390 chipset. I have the ASRock Z390 Phantom Gaming 4 MoBo so the poster might have been on to something. If you go into the BIOS, go to the CPU Configuration section and disable the C-State options the problem totally cleared up. But I didn’t like the idea of shutting off all the C-States at all times and found out (at least for me) my problem completely went away when I turned off the C3 state specifically.

 

I wanted to post this because I could not for the life of me find a solution to this anywhere but I hope this helps someone. Thanks.

 

TL:DR - If polling rate is causing a lot of issues for you and you have a Z390 chipset MoBo, try turning off all C-states/just the C3 state and see if it works for you.

  • Thanks 1
Link to comment
Share on other sites

  • 1 month later...

Did you find it increased your power usage?

 

I think it's something to do with the AsRock Z390 Motherboards, honestly. Everyone with an issue has some form of AsRock Z390. I'm seriously considering ditching AsRock and buying a new motherboard. Just going to be a pain reformatting my PC for the new MoBo :(

Link to comment
Share on other sites

  • 2 months later...

Hello! I made an acoount just to say thanks. I just got an ASRock Z390 Extreme4 and have been pounding my head for a couple days, disabling the C3 state fixed everything.

 

I'll add my troubleshooting in case anyone else should end up here. I noticed overall system lag/frame drops/stutters pretty much everywhere: windows, programs, games, etc. I troubleshot all over the place including mobo/chipset drivers, disabling the asmedia sata controller (I have a bunch of drives connected), RAM, GPU, boot drive and programs. I definitely noticed through my troubleshooting if Corsair iCue OR EA's Origin was running it made the problem worse. Closing both made it mostly go away. Origin was a bigger culprit than iCue. In some games I could move my mouse in the menu and my FPS would go down to single digits. Finally I thought maybe a polling rate issue, I have a logitech g9x (still!) and I lowered the polling rate to 125 and the problem seemed to go away. Tested back on 1000hz at https://zowie.benq.com/en/support/mouse-rate-checker.html and found it to be all over the place, bad polling rate drops. That's when I found your suggestion. Turned off C3 and now polling rate is 1000hz, origin and icue running in the background, and all seems good.

Link to comment
Share on other sites

  • 3 weeks later...

Hi folks - I registered to provide an update on the mouse lag problem, which I also experienced in my Z390/9900KS/2070S rig.

 

So... like others around the web have mentioned, you CAN disable C3, and this will likely fix the problem. It certainly did for me. However, losing C-States bugged me a little, so I continued to investigate.

 

Long story short - I think this is not so much an iCue problem exactly, but rather a software conflict between a very specific type of software and Windows and the Intel Management engine.

 

If you're the adventurous type and don't mind making a registry entry, then you might want to try adding this DWORD to the Intel Management Engine hive. It completely fixed my mouse lag, and I was able to reinstate all of my C-States. I even reversed it to confirm that the problem came back, and it did.

 

Here's the entry: in HKLM\SYSTEM\CurrentControlSet\Services\MEIx64\Parameters\, add the DWORD value PG_DISABLED, and set the value to 1.

 

https://forum.corsair.com/forums/album.php?albumid=847&pictureid=2160

 

EDIT: I believe the "PG" in the registry key stands for "Power Gating", and is a sub function of Intel's Power Management. Somehow, leaving this feature enabled creates a conflict.

Edited by cathammer
Clarification
Link to comment
Share on other sites

  • 2 weeks later...

Tried but still had some stuttering, not as bad as before tho. I am going to stay with disabling C-STATES

 

Hi folks - I registered to provide an update on the mouse lag problem, which I also experienced in my Z390/9900KS/2070S rig.

 

So... like others around the web have mentioned, you CAN disable C3, and this will likely fix the problem. It certainly did for me. However, losing C-States bugged me a little, so I continued to investigate.

 

Long story short - I think this is not so much an iCue problem exactly, but rather a software conflict between a very specific type of software and Windows and the Intel Management engine.

 

If you're the adventurous type and don't mind making a registry entry, then you might want to try adding this DWORD to the Intel Management Engine hive. It completely fixed my mouse lag, and I was able to reinstate all of my C-States. I even reversed it to confirm that the problem came back, and it did.

 

Here's the entry: in HKLM\SYSTEM\CurrentControlSet\Services\MEIx64\Parameters\, add the DWORD value PG_DISABLED, and set the value to 1.

 

https://forum.corsair.com/forums/album.php?albumid=847&pictureid=2160

 

EDIT: I believe the "PG" in the registry key stands for "Power Gating", and is a sub function of Intel's Power Management. Somehow, leaving this feature enabled creates a conflict.

Link to comment
Share on other sites

Thank you for the suggestion but I too found the registry suggestion to not work as well as disabling C3 state in bios. Kind of a bummer but I have not noticed any adverse affects in disabling C3. Not sure exactly what it does but I'm able to sleep, hibernate without issue. Turbo mode works as expected and it clocks down when under light to no load. Very weird still!
Link to comment
Share on other sites

  • 3 months later...

Disabling C3 state definitely solves my problem with this board and laggy explorer. I can now run iCue without any problems.

 

I'm running an Asrock Z390 Phantom Gaming 6. So there must be some issue with Asrock's UEFI or board design/implementation of the Z390 chipset.

Link to comment
Share on other sites

 Share

×
×
  • Create New...