Jump to content
Corsair Community

K95 RGB Platinum died?


silverr
 Share

Recommended Posts

Hi all, yesterday my keyboard was working fine (apart from a few keys that would have red RGB lighting no matter what lighting design I was using), and today I went to go get onto my PC and the RGB lit up but the keyboard itself wasn't working. I restarted my PC, still didn't work. I tried switching USB ports (tried everyone on my machine) and it still didn't work and by this point the RGB wasn't even coming on. I left for about an hour and came back and my keyboard now has a single red light lit up on the bar at the top right. Any ideas if its dead or what happened?
Link to comment
Share on other sites

Since the last update, my K95 Platinum will also randomly hard freeze, icue will stop and I have to cold reboot because I'm in a game where I can't get out without the keyboard or Cntrl-Alt-Delete. Typing this now on an old Logitech keyboard that just works whenever I plug it in without software. I've got void pro rgb, dark core se, k95 platinum, st100 headphone stand, corsair case and memory. This is new behavior. I have to climb under my desk, unplug the dual keyboard plugs, reboot, plug back in and hope it works. Has taken a couple of times to be recognized. Like OP, not sure if K95 is going bad or it's an iCue problem, but it always happens in the middle of a game. My k95 about 6 months old. Anyone got any troubleshooting help? Not sure how to troubleshoot a keyboard, as I've never had a problem with one before.
Link to comment
Share on other sites

 Share

×
×
  • Create New...