Jump to content
Corsair Community

New iCUE Patch Ruined my Firefox Browser


platysaur
 Share

Recommended Posts

I know it sounds weird but it's the only thing I can find a link to. I was on Firefox as I was downloading the latest update for iCUE. After the update, my Firefox browser runs slow as hell. Videos are very laggy and delayed. I downloaded Chrome and it works perfectly, so I went and uninstalled Firefox, deleted everything, yet it still runs slow. I'm positive that the iCUE patch has to be the issue because it only happened after I downloaded the patch.

 

Edit: I discovered that the new update turned my GPU off. It was using Microsoft display adapters. I had to install the latest update for my GPU (one I did before) and it now works. What the hell, Corsair???

Edited by platysaur
Link to comment
Share on other sites

Hard to say what's going on as you've neglected to fill out system specs.

I will say, however, that this is likely an isolated occurrence. If it was common, we'd see a LOT of folks on here screaming. I can also say that I've not seen this on any of my systems (and I also use FireFox).

Link to comment
Share on other sites

Edit: I discovered that the new update turned my GPU off. It was using Microsoft display adapters. I had to install the latest update for my GPU (one I did before) and it now works. What the hell, Corsair???

Did you install the Windows 1903 update recently?

 

I've heard a number of people have had their NVIDIA driver disabled/removed during the update. As Devbiker stated, it may just be an isolated incident and you are working now so no need at this stage to call for a Spanish Inquisition.

Link to comment
Share on other sites

 Share

×
×
  • Create New...