Jump to content
Corsair Community

Corsair 3x HD120 + Controller & Hub Connection issue


Brooklin
 Share

Recommended Posts

Hi,

 

I connected everything. LEDs are working, but only fan is running. I connected this fan to a 4 Pin Connection on my Mainboard Aorus Elite X570. It has two Connections for System Fans. The other one is used by my rear fan. How do I connect the other two to the mainboard. As mentioned all three LEDs of the three Fans are working, but the other two fans are not running.

 

Please help there are no other Connections than These two System Fan C. and four but only for LED stripes.

Link to comment
Share on other sites

You need to connect them to a PWM capable 4 pin fan header. If you don’t have enough motherboard headers, you need to use PWM splitters to pair up fans. No 3 way splitter for the HD120 - 2 way splitter only.

 

The other option is a powered fan hub or fan controller. The powered fan hub usually has a power source from the psu (like a SATA cable), then a single speed control wire that connects to the motherboard. You can put 3-5 fans on a powered splitter.

 

The most useful of all of these would be a Corsair Commander Pro Fan controller. It has 6 independent fan headers that are software controllable from the desktop. No more bios diving to make adjustments. Perhaps better still is it will also allow software control over the HD fans. I am guessing you are just using the thumb remote right now. That gets tiring really fast, possibly from the brightness level alone. It allows individual control of fan lighting and access to all of the colors and patterns. The Commander Pro is the most expensive of these options, but has other benefits the prior solutions do not.

Link to comment
Share on other sites

 Share

×
×
  • Create New...