Jump to content
Corsair Community

New K68 not usable until the OS loads


Ascaris
 Share

Recommended Posts

Hi,

 

I posted a comment about this on another thread, but that was about a different product, so I posted anew.

 

I have had a Corsair K70 for about five years, give or take. It's worked fine for all of that time, until just a few weeks ago, when it suddenly quit working. I've been moving it from my desk to the back of the computer case a couple of times a day for about as long as I have had it, and I guess one of the wires in the cord assembly had enough. If I hold the cord just right, it works.

 

So, I bought a K68 to replace it. I like the K70 a lot, but the K68 is spill resistant, which was why I changed models.

 

Now I have discovered that I have the same issue as a lot of people here... when the PC first boots, the scroll lock light flashes, and the PC will not respond if I hit DEL to enter the UEFI settings. When the GRUB menu comes up to allow me to select an operating system to load, the keyboard does not work there either.

 

Once the OS begins to load, the keyboard lights go out and come back on, and at that point the flashing of the scroll lock light stops. The keyboard is once again usable.

 

I read that it is possible to get the keyboard to work preboot by pressing F1 + WinLock. That's supposed to make the scroll lock key flash, but it already is, so there's no visual confirmation that the key combo was pressed. Still, it does work.

 

I don't go into the UEFI very often, but I do use the GRUB boot menu a fair bit. My K70, with the hardware switch set to 1ms report rate (the fastest possible), never had this problem. My PC is an older one, with an Asus P8P67 Deluxe motherboard, but I see all kinds of people reporting the same exact issues with brand new, state of the art motherboards. EDIT: I just tried booting with the K68 plugged into my Acer Swift 1 laptop, a current model still in production, and I got the same flashing scroll lock light, and the keyboard does not work until the OS loads, exactly the same as my desktop with the P8P67 motherboard.

 

I put in a ticket, and the agent told me that "the keyboard will not be detected due to driver issue basically the motherboard doesn't new and modern keyboard, it would be best to get a PS2 keyboard and make sure to enable LEGACY keyboard."

 

I put in the ticket that my K70 had worked for years, and he's telling me to go get a PS/2 keyboard?? Sheesh, how long have USB keyboards been the norm now?

 

Clearly, with all of the people reporting this problem with other brand new boards, it's not an issue with the age of my board. As with my M95, it seems that there is a firmware issue with this keyboard, and I hope it doesn't go into EOL with the issue still outstanding like the M95 did.

Edited by Ascaris
Additional info (in bold)
Link to comment
Share on other sites

 Share

×
×
  • Create New...