Jump to content
Corsair Community

MP510 ECFM12.2 to 22.5 - Firmware update failed


Recommended Posts

I have MP510 with Win10 installed on it.

There are two other drives: Crucial MX500 and WD HDD.

Corsair SSD Toolbox v1.2.5.7

Toolbox reports that there is update for SSD from version 12.2 to version 22.5.



When I click update it downloads firmware, but then fails during installation.




What am I missing? Is it because W10 is installed on this drive? I checked BIOS and SATA is in AHCI mode.


Please advice on how to update the firmware.



Link to comment
Share on other sites

AFAIK, the latest firmware for the MP510 is ECFM12.3 (see my other posts https://forum.corsair.com/v3/showthread.php?t=188547 ).


ECFM22.5 just sounds completely wrong. Google it and you will get no results.


Just another Corsair software screw-up I fear :roll:


Are you talking about this thread https://forum.corsair.com/v3/showthread.php?t=188547 ?


Would you recoomend to update from 12.2 to 12.3.


Thread https://forums.overclockers.co.uk/threads/firmware-12-3-info-for-nvme-drives-using-the-ref-phison-e12-controller.18859737/ says that firmware update is destructive and I will loose all my data. I don't want to re-install windows and all the software again...


As I understand you used Phison utility for that?




Actually, nevermind, I already upgraded to 12.3 following your advice... Everything went smooth and easy. Data is wiped only when updated from version 11.

Edited by fatum2002
Link to comment
Share on other sites

Hi all, this was a bug in the updater, and was fixed last night. 12.3 is the newest firmware for the MP510, so please disregard.


Thank you!


I'm getting the same error when trying to update from 12.2 to 12.3 via official updater. Still a bug? it says "firmware update failed"

Link to comment
Share on other sites

I was initially getting the same thing, failure to download firmware 22.5.


I just ran Corsair SSD Toolbox again and it correctly saw 12.3 (so fix worked) and it downloaded and installed without any problem, required a restart. I upgraded my C: (OS) drive, running Windows 10.

Edited by Furyan
Link to comment
Share on other sites

My drive is still failing to update. When I try to update it is showing the available firmware version as 22.5, not 12.3. See the screenshots below. I am on SSD Toolbox version and have restarted. Even tried uninstalling and reinstalling SSD Toolbox and restarting again. No change.









Update 10/10/2019: Just wanted to let you know, I tried again today and the update to 12.3 went fine. It was probably due to the caching issue "Corsair Kevin" mentioned below. Unfortunately I didn't see that post till just now. But it looks like the caching issue resolved itself over time. All is good now. Thank you!




Edited by joelslaw
Status Update
Link to comment
Share on other sites

Hey there.


I installed an MP510 with 960GB in my new ASUS GU502G past weekend, and restored Windows with an image I made before. This far - no problems at all. System is fast and reliable as before. Installed the latest version of the SSD Toolbox from the Corsair website.


But - the Corsair SSD Toolbox does not show all infos. I don`t get temperature readings nor infos about how many bits and bytes have been written before.


The firmware version installed shows EFCM22.5. The button for upgrade is not avail. Installed the toolbox three times - all with the same problems. Tried the troubleshoot explained above - didn`t helped.


Any idea?


Thanks in advance.


Edited by indubioproretro
Link to comment
Share on other sites

And I made a clean install of Windows 10 (1903) this week on this MP510 SSD - and again the Corsair SSD Toolbox ( and CrystalDisk SSD Info show me, that this SSD has the firmware "ECFM22.5" installed.


I can hit the update button, but this only tells me that I already have the latest firmware installed. Rebooting, or "abuse" of the ipconfig tool didn't helb either...

Link to comment
Share on other sites

  • 4 weeks later...

  • Create New...