Jump to content
Corsair Community

K70 Lux RGB LED wont light up


anamaroth
 Share

Recommended Posts

Another day, another issue with a corsair product;

 

Bought K70 Lux, RGB wont light up at all, even after ICUE setup. ICUE detects the keyboard, and says it needs an update, however pressing the update button immediately produces an error "Failure to check for firmware update". I've tried plugging it in different USB ports, no positive results.

 

Edit: I should probably add that 3 led indicators near the multimedia keys keep blinking. No idea what that means.

 

Edit2: doing the soft reset as described here:

solved the issue Edited by anamaroth
Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees

Hi,

 

We recommend performing a clean install of iCUE. Please follow the steps below:

 

 

 

Open your computer's Control Panel.

Open the Programs and Features options.

Select Corsair Utility Engine in the list, and then select Uninstall.

Open your Start menu and type "Run". Then open the Run option.

Type Regedit and then click OK.

Navigate to HKEY_CURRENT_USER\Software\Corsair\Corsair Utility Engine

Right-click and delete the folder.

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Corsair\Corsair Utility Engine

Right-click and delete the folder.

Restart your computer.

Download a new installer file for iCUE from Corsair.com and reinstall.

 

 

If you need assistance with these steps, please reach out to our support team.

 

If you have more issues please create a support ticket for further troubleshooting assistance.

 

Kind Regards,

Link to comment
Share on other sites

 Share

×
×
  • Create New...