Jump to content
Corsair Community

ICUE wont open


brettol
 Share

Recommended Posts

Hi, I am having some problems with Icue, it won't open although it's running in the background as I can see from task manager.

I have un-installed and re-installed I have also manually deleted the corsair files from the registry and still no luck.

 

Anyone have any ideas?

Link to comment
Share on other sites

  • Replies 81
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Same issue here..ive unistalled the software, ive deleted the registry from local machine and local user, ive delete the folders from appdata installed the software and still nothing. give us an awnser bcoz im trying 8h's now to figure it out and nothing helps..
Link to comment
Share on other sites

What are your system specs? Have you updated Windows and system drivers?

 

CPU: AMD FX 8350 4.2GHZ

MOBO: GIGABYTE GA78LMTUSB3

RAM: CORSAIR VEGEANCE 16GB DDR3 1600MHZ

GPU: AMD RX 590 SPECIAL EDITION

OS: WINDOWS 10 PRO x64

 

MOUSE: CORSAIR HARPOON RGB PRO

KEYBOARD: CORSAIR K70 M.K2

 

Thats my pc spec everything is updated i even made 2 formats in 1 day bcoz i was mad.. the only possible reason im thinking is that my mouse or the keyboard makes the app to run incorrectly if they have internal memory(i have them 1 week now so idk if they have or not). I hope some1 will have the awnser bcoz its frustrating. Thanks.

 

 

P.S Sorry for my bad spelling English are not my native lang.

Link to comment
Share on other sites

Make sure an antivirus isn't blocking the exe from loading. Sometimes antivirus software can be a bit overzealous.

 

well its not antivirus issue or windows firewall... the app is opening as the task manager says including with the services of corsair but the iCUE Window wont appear at all!

Link to comment
Share on other sites

[iCUESetup_3.20.80_release.msi]

 

Extremely High CPU Consumption

The program is open in the Windows task manager but does not open the screen.

 

Already removed with Revo Unistaller

I already removed the drivers

I already formatted the computer

I do not use antivirus

Using a firewall, even turning it off or on makes no difference

 

I installed an earlier version [CorsairUtilityEngineSetup_3.1.133_release.msi] and it worked perfectly, but when I asked to upgrade, the same problem came back.

 

W49wtFy.jpg

Link to comment
Share on other sites

I'm having the same issues. I have done everything any person would have done. Ths issue is that I have a Corsair AIO which means that since icue is not working, my AIO fans are set to the lowest setting and my computer CPU can't handle that. Temperatures sky-rocket whenever I go into a game and I was forced to not play any games. icue stopped working after the recent update. Same situation, icue shows up in the task manager but does not have its user interaction menu open. I hope Corsair fixes this immediately.
Link to comment
Share on other sites

The only solution I have come up so far which would be a temporary fix until the next update would be reinstalling the previous version of iCue.

 

Here: http://downloads.corsair.com/Files/CUE/iCUESetup_3.18.77_release.msi

 

Thanks K1LL3R for the download, I'm still kind of a newbie with computer stuff and didn't know how to go back to previous versions of iCUE. I hope they fix this stuff soon

Link to comment
Share on other sites

Well it seems no1 cares about this problem from Corsair team nad its kinda sad because i used to liked this company and i was ready to build a pc with almost everything from Corsair as i have on my old rig...anyway thanks Corsair for doing nothing!

Btw it seems a lot of ppl have this problem and u still dont care!

Link to comment
Share on other sites

i'm having this problem too.

 

it's because the software crashed again. if you can't click the icon in the taskbar and it wont show up but is running, then its cuz this buggy excuse for software has once again hit the wall.

 

seems 3.20 is pretty bad, wasn't having the troubles with 3.18 (avoid 3.19 at all costs, the worst offender of them all).

 

to fix it (temporarily) you have to kill icue in Task manager and then restart the corsair service

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...