Jump to content
Corsair Community

iCUE 3.19.120 causes large FPS drops in WoW and Overwatch


Slashee the Cow
 Share

Recommended Posts

So don't ask me why or how, but for the past few days I'd suffered significant FPS drops playing WoW and Overwatch but not any other (non-Blizzard) games. I have WoW set to a 60fps cap and Overwatch set to 120, which they're both able to maintain fairly well, but the framerates tanked down to 30-40 for WoW and 80-100 for Overwatch. The GPU and CPU were reaching nowhere near 100% utilisation so it was like they weren't even trying.

 

Couldn't figure out why, tried everything (including ending the iCUE process and stopping the Corsair service, which is why I initially thought it wasn't the culprit), but getting more and more desperate I uninstalled iCUE, rebooted and tried it and the games ran fine. Reinstalled iCUE 3.19.120, games run like crap. Uninstalled iCUE again, rebooted, found a download for an earlier version (3.18.77), installed that, WoW and Overwatch run fine now.

 

So now I just have to recreate my profiles (tried opening the profiles and changing the version number in them, still says they're from a newer version) and deal with the fact that I don't seem to be able to control the lighting on my Vengeance RGB RAM individually (the selector on the right for which stick the effect should apply to just says "true" for each stick and clicking them does nothing, but that's a minor problem compared to your favourite games turning into a slideshow).

Link to comment
Share on other sites

 Share

×
×
  • Create New...