Jump to content
Corsair Community

Leaking H100i Platinum SE (2000817174) UK


VC1
 Share

Recommended Posts

Hi Corsair

 

I sent in a RMA request over 2 weeks ago as my H100i Platinum SE is leaking.

2 weeks have passed now and I am left without a computer. I sent a copy of my invoice with all my details etc with my original RMA form, I got a email asking for my details a few days later :(

So frustrating, why does it take so long to get a replacement. It has been over 2 weeks now and imagine it will be a few more to send this back and get another sent out.

 

Ticket No.2000817174

Link to comment
Share on other sites

  • 2 weeks later...

Hi

 

I got a replacement cooler the other day, when i first installed the cooler it was making a funny noise, its now been running for 3 days or so and it sounds horrible. I thought it was just because it had been moving about in shipment, I have been toggling in between the modes to see if it changes at all but it does not. The one that it has replaced did not make these noises and was very quiet.

 

[ame=

]
[/ame]

 

Video starts off in quiet mode, then switches to balanced and finally performance mode. It's super loud in quiet mode and has a hard drive clicking type noise, balanced seems to be quieter but has a weird bubbling noise, performance mode is the quietest but it's more of a high pitch noise and oddly has a dripping sound :(

Link to comment
Share on other sites

  • Corsair Employees

Hello,

 

I cannot see the video here as it isn't loading. Have you tried asking in the cooler section in our forums for trouble shooting? If you need someone to look into another replacement then I can see if I can get someone for you, other wise you might need to go there and ask.

Link to comment
Share on other sites

Hello,

 

I cannot see the video here as it isn't loading. Have you tried asking in the cooler section in our forums for trouble shooting? If you need someone to look into another replacement then I can see if I can get someone for you, other wise you might need to go there and ask.

 

Hi

 

Could you get a replacement out for me, I have tried to give this a few days just to see if it will settle down as it may be from transport but there is most certainly something wrong with this, it is makes a horrible noise in all modes and in Extreme mode it sounds like a dripping tap.

 

https://drive.google.com/open?id=1-mk-O85TBFk-3Wh3bztqxepI0tGek4sR

Link to comment
Share on other sites

 Share

×
×
  • Create New...