Jump to content
Corsair Community

iCUE not working properly with ST100 (EQ, voice prompts, Surround not working)


waldo15
 Share

Recommended Posts

Folks,

 

So I just upgraded to the latest iCUE version (3.19.120) and I have noticed that the software no longer is able to work properly with my ST100. Here's the current status:

 

Working

  • I can hear audio with my stereo headsets just fine.
  • Microphone works

 

Not working (they worked prior to 3.19):

  • EQ presents do not do anything. I have switched all the EQs that come with the software (FPS optimized, Bass Boost, etc.) and the audio does not change at all
  • I no longer get audio prompts from iCUE when I turn on/off my mic, my surround sound, etc.
  • I press the surround sound button to enable/disable it and nothing happens. I am not sure in which state my headphones are stuck, though windows reports an 8 channel audio device connected at all times

 

troubleshooting tried so far

  • Uninstalled software and cleaned registry
  • Unplugged the ST100
  • Installed the latest iCUE version
  • Rebooted machine
  • Plugged in ST100. It gets detected, I get audio from it but symptoms described above persist

 

System specs

  • MSI Z390I Gaming edge AC
  • Intel i7-9700K
  • Windows 10 latest updates installed (up-to-date to Sept '19)

Any idea or pointers to fix these issues is greatly appreciated

Link to comment
Share on other sites

Update: After much tinkering, I decided 3.19 was too much trouble to bear so I decided to uninstall everything and re-install previous version 3.18.77. I am back to full functionality where all voice prompts work, I can enable/disable surround sound at will and equalizer presets work as intended.

 

I would strongly recommend Corsair to fix whatever issues are messing this newest release.

Link to comment
Share on other sites

 Share

×
×
  • Create New...