Jump to content
Corsair Community

iCUE running on taskmanager, not opening


fly_hi
 Share

Recommended Posts

Today I updated my iCUE software, restarted my PC and then it just never opened again. It runs on the task manager, however I can't open it, and it's not on the system tray.

 

What corsair products I have:

  • Corsair Void RGB
  • K70 RGB

 

Things I've tried: (I've restarted my pc before and after every attempt)

  • Restarting PC.
  • repairing
  • uninstall/reinstall (with and without keeping profiles)
  • deleted %appdata% caches
  • deleted config and tried to reopen after closing iCUE
  • unplugging my devices
  • uninstalling the drivers for keyboard and headset
  • uninstalling the drivers for keyboard and headset then reinstalling
  • Running as administrator

 

I've googled to try and fix this issue and those are all the things I have found. But after 3-4 hours none of these are working.

 

To mention, the software is using an abnormal amount of CPU usage after the install.

 

Ok, I went back to 3.18 and it works again. If anybody has this issue, go back.

Edited by fly_hi
Link to comment
Share on other sites

 Share

×
×
  • Create New...