Jump to content
Corsair Community

Corsair Hydro 115i RGB Platinum, thermal paste only sticking to right half of CPU...


Jarambo
 Share

Recommended Posts

Hi i got a Corsair Hydro 115i RGB Platinum to replace my broken 100i and the temperatures are not good. Took off the pump from the CPU and noticed the thermal paste pre-applied to the cold plate is only making contact with the right hand side of the CPU. Tried making screws tighter etc, same problem. I even took off the backplate and put some washers around the bits the standoff's screw into and still have the exact same problem. The only way i can see to make it cool half decent is by putting a lot of thermal paste on the CPU to force it to have more contact......and even then it's idle at 32c which is bad because my 100i was almost bang on 25c when it was idle. I do not like how much space there seems to be between the left hand side of my CPU and the coldplate, the thermal paste is showing me it's not even making contact with it at all which is shocking. I'm wondering could i use the backplate and the other parts of my h100i on the 115i RGB and see if it fixes the issues? The only thing i could imagine doing this would be the standoofs that came with the cooler......using the original ones i had with the h100i might fix it? Just looking for an opinion before i try anything incase the screws are a tiny bit different or something? Edited by Jarambo
More info.
Link to comment
Share on other sites

  • 2 weeks later...
Hi it's been a while and i was hoping i'd get an answer here before i start messing around with the pump/backplate again. Anyone got any idea's/suggestions on what to do or is the product defective? I want to try using the old backplate/standoffs from my old corsair cooler and don't want to go ahead with this until i know for certain that it's not gonna damage anything and be compatible.
Link to comment
Share on other sites

 Share

×
×
  • Create New...