Jump to content
Corsair Community

Crystal 570x - Fron and power led not lightning up


Gydo89
 Share

Recommended Posts

Hi there,

 

I've been checking all the posts related to this topic but actually couldn't find anything that could help me solving this issue...

 

I recently built my PC, and everything works well, except the front LED logo and the power button.

 

The pins are connected to the Power LED pins of the motherboard in the right position (I triple checked it) and none of the LEDs work.

 

Just to see if it was a problem with the motherboard pins and not the LEDs/cable, I plugged them into the HDD LED pins, so it would blink instead of being static... But with no result either...

I also tried to change the order of the cables just in case the polarity was switched, but with no success :(

 

 

Is there anything I am missing? I checked that the joint of the cable is properly attached too. Everything looks correct and I tried everything I could think of.

 

 

Hope somebody can throw some light! (literally lol)

 

 

Thank you!

Edited by Gydo89
Link to comment
Share on other sites

 Share

×
×
  • Create New...