Jump to content
Corsair Community

LL 120 RGB Fans Problems (Artifacts & Improper Operation)


Sesscar
 Share

Recommended Posts

I built my PC weeks ago and installed Corsair LL120 RGB fans later on for a better airflow.

 

It works completly fine before I installed the iCUE software and then choosed the wrong "Lightning Channel 1" for the fans, I think i choosed HD RGB Series fans and then switched to LL and now I think it has corrupted my LL120 Fans(3 of them).

 

I tried uninstalling software and everything but it doesn't revert the damage.

 

I really need help because of my stupidity.

 

It seems like the lighting effect is different and not as bright as it was before I messed it up.

20190822_212733.thumb.jpg.8a14a9b5a976db9ec6ab3a7043c22403.jpg

Edited by Sesscar
Link to comment
Share on other sites

Pssh Good Luck. These fans though they look great are one of the worst purchase decisions I've made in recent memory. I bought 6 of them and have constant issues where they will magically work, then suddenly one or two will freeze, then I reboot and two different ones won't turn on all together. If I switch between hardware lighting and a profile I made like Arc some of the fans will switch while others remain stuck on hardware lighting. I've tried the typical canned answer of troubleshooting the fans 1 by 1 and I get no consistency as to which fans will work and which won't. I'll plug a fan into slot 1, works fine, can switch profiles, turn a fan into slot 2, works fine then I put a fan into slot 3 and it won't light up. Oh, must be fan 2 is the problem then. Swap fan 2 for fan 3, both work, put previos fan 2 into slot 3, lights up just fine, put a fan into slot 4, lights up just fine. Put a fan into slot 5, nothing. Remove all those fans and start over, completely different result. Something is significantly wrong with iCue and/or the most recent Firmware version. When I have a chance I'm ripping all 6 of these LL120's out of my case and replacing them with something else. I'm done with Corsair all together after this.
Link to comment
Share on other sites

The Lighting set-up simply tells the software how many LEDs are in play and how to time the effects. HD X 6 creates a 12x6=72 LED series of effects. LL x 6 does the same but for 16x6=96 LED. It does not alter current, power, or anything that could damage the lighting elements and people do use mixed HD/LL sets together.

 

Are you sure the lighting effects are less bright? There is a brightness slider in the settings for the control device (LNP or C-Pro) and also on the LED level with the slider circle.

Link to comment
Share on other sites

The Lighting set-up simply tells the software how many LEDs are in play and how to time the effects. HD X 6 creates a 12x6=72 LED series of effects. LL x 6 does the same but for 16x6=96 LED. It does not alter current, power, or anything that could damage the lighting elements and people do use mixed HD/LL sets together.

 

Are you sure the lighting effects are less bright? There is a brightness slider in the settings for the control device (LNP or C-Pro) and also on the LED level with the slider circle.

 

yep, I've checked it and it is set to brightest, I think what changed is that the default setting when freshly installed the fans are gone and now it's stuck with iCue rainbow default effect which is different than the factory default setup?

Link to comment
Share on other sites

 Share

×
×
  • Create New...