Jump to content
Corsair Community

iCUE software (3.18.77) not detecting Corsair M65 Gaming mouse


Crossair
 Share

Recommended Posts

Dear all,

 

In order to configure the sniper button on my Corsair M65 gaming mouse, I downloaded the iCUE software. Unfortunately, the software detected anything but my Corsair mouse.

 

What I have tried (restarted PC between each try):

-reinstall iCUE several ways;

-unplugging USB's wait for 20 sec;

-deinstalled Corsair composite virtual input device;

-repair iCUE;

 

None of the above methods have solved the problem. What is especially strange to me is that iCUE does detect any of my other hardware devices. Except my Quickfire TK keyboard and Corsair M65 gaming mouse.

 

Do any of you know any other methods I could try so that iCUE can see my m65 mouse so that I can alter the sniper button to my liking? Any suggestions around iCUE are fine as well. As long I can disable or alter my sniper button.

 

Cheers!

 

p.s. other specs:

- AB350-Gaming 3

- AMD Ryzen 5 1600

- AMD Radeon RX 580 Series

- LG MP59G Monitor

- Corsair M65 Gaming mouse

- Quickfire TK Keyboard

Link to comment
Share on other sites

 Share

×
×
  • Create New...