Jump to content
Corsair Community

Firmware/icue issues


Recommended Posts

It all started with the volume wheel getting stuck (not phisically) sending an infinite loop of volume input not allowing any other kind of input to reach the computer. As suggested i checked if it was an icue issue using the keyboard without icue running for a while. Today i started icue again, and the volume wheel issue occurred again (didn't happen for the whole time i used the keyboard without icue).

I unplugged and re-plugged the keyboard which solved the input being stuck issue. It still works like normal keyboards, but now almost everything cue related doesn't work. Macros, remaps, rgb. I found out writing code on Visual Studio (i have my italian layout ò key remapped to altgr + à (which prints #)) but the # doesnt appear, and neither does ò, as if the original key has actually been overridden but the macro i set is being ignored. I tried updating icue, there was an update, and i installed it (3.18.77). Checked for keyboard firmware updates, and nothing was available (3.21.7168). Tried to force firmware update in case something in the keyboard was corrupted, but the process made icue crash upon reaching 2%.


Is this an hardware issue with the keyboard, a software issue with keyboard's current firmware, a software issue with icue? Can i do something for it? Should i ask for a replacement?

Edited by Barnack
Link to comment
Share on other sites


  • Create New...