Jump to content
Corsair Community

Dark Core RGB Sleep Mode Issue


Robbie_Jardine
 Share

Recommended Posts

I am having an issue with my Dark Core RGB mouse. I have enabled Sleep Mode to activate after 15 minutes, however the device enters sleep mode after a few minutes of inactivity.

 

This can be very frustrating especially as the mouse ignore what is set in iCue, I have tried to uninstall and reinstall iCue and reflashing firmare to no avail

 

RGB Dark Core Firmware - v3.35

iCure version - v3.18.77

Windows 10 Pro 1903

1998671254_Screenshot(13).thumb.png.eb55d95156a5a2a45a19596dca83ebce.png

Link to comment
Share on other sites

Hey dude,

Had the exact same problem with my Dark Core, only it timed out every 60 seconds, very, VERY frustrating...

I established that this **** happens sometimes after charging the mouse with the cable. Couldn't identify an exact pattern, unfortunately... You can fix this by uninstalling (NOT repairing, uninstalling) the iCUE software WITH deleting the profiles (there is a checkbox for that during uninstall) and then installing it again.

I somehow managed to prevent this from happening for myself, not sure exactly how, but here are some things I started doing:

 

- Stopped playing around with the iCUE profiles. Unfortunately, I think that doing so is the reason for the malfunction;

- I started recharging the device overnight while it is turned off. I am pretty sure that one time the issue happened to me after plugging in the cable and using the mouse. Corsair have decided to make the iCUE too complicated, the mouse seems like it loads different profiles when on dongle, bluetooth and wired, crazy ****...

- Lowered the device and dongle polling rates. The device's one you can alter when the mouse is connected with the cable.

 

Hope this helps dude, share results. Cheers!

Link to comment
Share on other sites

I am having an issue with my Dark Core RGB mouse. I have enabled Sleep Mode to activate after 15 minutes, however the device enters sleep mode after a few minutes of inactivity.

 

This can be very frustrating especially as the mouse ignore what is set in iCue, I have tried to uninstall and reinstall iCue and reflashing firmare to no avail

 

RGB Dark Core Firmware - v3.35

iCure version - v3.18.77

Windows 10 Pro 1903

 

I have the same problem. It seems than when I start/restart computer that 15 minutes inactivity timer is working correctly but then after couple of days computer usage (with many times putting computer to sleep) mouse starts to sleep after one minute inactivity. Off course shorter sleep duration saves battery, but this mouse has so slow wakeup (compared to competitors mouses) that it sometimes drives me crazy (e.g. writing something for minute or two, then I have to do something with mouse, but mouse sleeps already so I have to either move mouse rapidly all over the mousepad or push button and wait that second or two so it will wakeup and starts to work)

 

This problem appeared after updating to latest v3.35 firmware.

 

Also with this newest firmware it seems that when I put computer to sleep then sometimes mouse doesn't go to sleep. Instead mouse goes to HW profile and starts changing colors. This won't happen every time, I would say it only happens once in 5 to 10 sleeps. I think that I didn't have this problem with that older firmware.

Link to comment
Share on other sites

I have just bought one of these and its doing my head in keeps bloody stopping and completly useless .

 

Complained to corsair and awaiting a reply :mad:

 

Or you can search the forum and read the solutions there, instead of just making a new post for something that has been discussed in a dozen other threads.

Link to comment
Share on other sites

Or you can search the forum and read the solutions there, instead of just making a new post for something that has been discussed in a dozen other threads.

 

Yes I could do but it seems corsair have problems with this product and the more people post about it the quicker a solution may be found .

 

As you can guess im new and I do understand how forums work :bigeyes:

Link to comment
Share on other sites

The issue is as such:

 

1) After a recent firmware update, Sleep timer is set really low by default.

2) profiles are not applying stored setings

3) Further confusion if using wired or dongle, as soft profile "Default" my be being used vs using a hardware profile.

4) When using BlueTooth, it will only use a hardware profile, so if you change the setting in "Default" it's not saved in the HW profile.

 

My solution:

 

1) Kill all the damn soft profiles. Not needed unless doing some macros. Wire up mouse.

2) Move desired HW profile to top of list so it becomes default.

3) Change Sleep setting to desired time. If it is already at the desired time, change it and put it back.

4) Save HW profile with Overwrite option. (You can change and save all three if desired)

5) Turn mouse off/on. Profit!!

 

Now, no matter what connection you use, the desired HW profile will be used with the desired Sleep setting.

Link to comment
Share on other sites

  • 2 weeks later...

After reinstalling Windows 10 Pro build 1903 I am still having the same issue as before.

 

I have attached my logs from iCue in hope that something will be found. One thing I have noticed is a continual entry about the RGD Dark Core firmware it appears in the log every few minutes, not sure if this is supposed to happen.

Logs.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...