Jump to content
Corsair Community

iCue Is Making Corsair Cooling Useless


kholt90
 Share

Recommended Posts

THIS IS A PSA. Do not buy any Corsair cooling products until this problem is fixed.

 

Several of us have been having a problem with iCUE related specifically to using custom fan curves. Basically, iCUE's hardware monitoring software freezes. The problem is persistent and it doesn't cause iCUE to stop working, only the hardware monitor to crash and anything using it to stop updating. This means your fans will stay at a constant speed, your AIO will stop working.

 

If anyone is having any problems with their cooling, it is most likely because Corsair is refusing to fix the problem. All they have to do is recode only the hardware monitoring part of the software and the problem is fixed.

 

Below is the link to thread in the iCUE forum if anyone needs more information. And if anyone know a permanent solution, let us know.

 

https://forum.corsair.com/v3/showthread.php?t=178964

Link to comment
Share on other sites

...This means your fans will stay at a constant speed, your AIO will stop working.

 

No, it does not mean your AIO "stops working". The pump continues to push coolant, fans continue to spin, and heat continues to be expelled from the system. You just can't watch it in the app.

 

 

All they have to do is recode only the hardware monitoring part of the software and the problem is fixed.

 

If it were that clear and obvious then all of us would be affected, but of course we are not. It is a smaller percentage, but that should tell you it cannot be as simple as "the hardware monitoring needs to be re-coded". Why are you affected and not the next 50 people using the app?

 

 

You have a thread where this discussion is taking place. It is long and clearly noticeable. This tactic is fairly juvenile and undercuts your credibility by misrepresenting the problem.

Link to comment
Share on other sites

Huh. That thread clearly illustrates Corsair support is abysmal. I just got a Corsair H80i V2 and will stay as far away from iCUE as possible. Management-heavy (vs engineer-heavy) companies always tell on themselves.

 

I'm glad this post was here: if I had that kind of third-world support from any American company, I'd realize how inept and lost they were.

 

Thanks for the PSA, OP. Keep pushing to keep these companies accountable. Don't mind the Corsair User Forum natives: they've been here too long and it shows.

 

Sheesh, people just wanted a CPU cooler, lol: how do ya screw that one up?...

Link to comment
Share on other sites

Huh. That thread clearly illustrates Corsair support is abysmal. I just got a Corsair H80i V2 and will stay as far away from iCUE as possible. Management-heavy (vs engineer-heavy) companies always tell on themselves.

 

You are having the same problem as the user above? No?

 

 

I'm glad this post was here: if I had that kind of third-world support from any American company, I'd realize how inept and lost they were.

 

Thank you for revealing your intelligence level. Someone like me will be around soon to terminate your employment rather than trying to educate you or bring you back into society.

 

 

Don't mind the Corsair User Forum natives: they've been here too long and it shows.

 

You have not been here long enough to come to any kind of informed decision about who or what I am. The above post was a suggestion not to overly exaggerate the issue and keep the details accurate so hopefully it can be solved. Screaming 'my cooler doesn't work and my PC is going to melt' is both factually inaccurate and does not help resolve the issue. However, having read your post above and the one you just made in the relevant thread, I suspect facts and accuracy are not things you worry about very much.

Link to comment
Share on other sites

New owner of a h115i platinum. Haven’t used my computer for a week because I spent two whole days troubleshooting why iCUE doesn’t register my h115i platinum. No RGB. No fan control. No recognition by iCUE yet windows shows h115i platinum AND USBDEVIEW shows it too! :-(
Link to comment
Share on other sites

New owner of a h115i platinum. Haven’t used my computer for a week because I spent two whole days troubleshooting why iCUE doesn’t register my h115i platinum. No RGB. No fan control. No recognition by iCUE yet windows shows h115i platinum AND USBDEVIEW shows it too! :-(

 

No doubt about it, the Platinum coolers have some quirks and the USB thing is pretty maddening. However, since that issue seems to be problematic for the Platinum alone, there surely must be a device specific angle to it versus strictly software. Either way, I am pretty sure you have seen the multiple threads for it. Your complaint is legitimate and I would continue to post as often as you want in those threads. No reason to associate with the above and if this gets turned into a "pile on" thread about 30 different issues with Corsair sucks as the main point of emphasis, people will just skip over it. It does help solve anything.

Link to comment
Share on other sites

Let me try to be more constructive and share what steps I took to troubleshoot. (All while windows and usbdeview successfully connected and reported the h1-5i platinum)

 

Full uninstall of iCUE (done after each install of each version tested. Specific folder deletion in appdata and ccleaner runs each time)

 

Tried iCUE .15, .17, .18 versions.

 

Tried different USB headers on MB

 

Tried connected USB from AIO to another PC

 

Tried 3 different USB cords.

 

Have done complete power down cycles even pulling the power plug and waiting a minute before reboots.

 

I’m out of ideas :-(

Link to comment
Share on other sites

I am sorry. I would gladly help if I could, but I do not have a Platinum cooler and the damn thing is different than all the others is many ways. I don't know what to recommend to you at this point. USB issues in general are really frustrating whether they are sound or device related. You seem to have done all the things you are supposed to try. I do not know what to suggest at this point. I think it is legitimate to consider returning it before it becomes too late. While the pump LED is slightly less complicated, the Pro series coolers are not afflicted with the same issues and have a good product history. You would loose the "in the box" RGB fans and have slightly fewer lighting patterns on the pump head, but also lose the headache. It is a lot less expensive because of the standard non-RGB fans. You can also take that savings and get whatever RGB fans you like or something different entirely.
Link to comment
Share on other sites

I get what your were trying to do and mathematically it makes sense while also obtaining a unique item (the high speed ML-RGB). However, you have run into a wall and things are not working as expected. You’ll have to decide whether to stick with it or jump ship. If you have not already, make sure you submit a Support Ticket to Corsair. That will be necessary for any formal remedy and this forum is just a discussion zone.
Link to comment
Share on other sites

New owner of a h115i platinum. Haven’t used my computer for a week because I spent two whole days troubleshooting why iCUE doesn’t register my h115i platinum. No RGB. No fan control. No recognition by iCUE yet windows shows h115i platinum AND USBDEVIEW shows it too! :-(

 

 

I had the same issue with mine, but was able to fix it. used ccleaner an uninstalled any software that could take over RGB (Precision X1, Gigaybytes RGB Fusion, etc). rebooted my machine and got the windows message "configuring h115 platinum, installing drivers" message and ICue recognized it. it's been working fine ever since.

Link to comment
Share on other sites

 Share

×
×
  • Create New...