Jump to content
Corsair Community

Corsair Dark Core RGB SE Disconnecting Itself


Dreadnaught503
 Share

Recommended Posts

For some reason my Corsair Dark Core RGB SE Keeps disconnecting itself or it's just stops responding and i cant use the mouse, I have to unplug my mouse from my pc then plug it back in to make it work again but after a while the mouse disconnects itself again. I am using Icue version 1.17.94 and my Dark core is version 3.35.
Link to comment
Share on other sites

Shut down iCUE and test the mouse. If the problem goes away, then kill your software profiles and remake from scratch. Resave your HW ones.

 

If problem persists, do a hard reset on the mouse. You could try a soft one first.

Link to comment
Share on other sites

I have been plagued by this issue since day 1.

I mentioned it here:

http://forum.corsair.com/v3/showthread.php?t=179666

and here:

http://forum.corsair.com/v3/showthread.php?t=184738

I have had every firmware and nothing helped, actually the issue probably got worse...

Finally opened a support ticket last week, but no one from Corsair has looked into it yet, that's a +7 days response time.

Link to comment
Share on other sites

  • 2 weeks later...
Shut down iCUE and test the mouse. If the problem goes away, then kill your software profiles and remake from scratch. Resave your HW ones.

 

If problem persists, do a hard reset on the mouse. You could try a soft one first.

 

How do you hard or soft reset the mouse ?

Link to comment
Share on other sites

The messages about the problem are getting more and more.

We need a fix on the software side and not a transition solution.

My mouse is new and the problem still exists.

Software or mouse resetting helps if at all only briefly.

Furthermore, missing since the last update of ICUE, the plus sign to adjust colors.

 

Corsair, please, please fix that!

Link to comment
Share on other sites

  • 10 months later...

Same problem here - brand new mouse (purchased 2 months ago).

 

Local reseller advises they won't replace on the spot because Corsair requires that it is sent in for inspection prior to issuing a warranty replacement.

 

This is a known engineering issue - you should be pre-issuing replacements for all vendors.

 

Please provide a resolution.

Link to comment
Share on other sites

  • 6 months later...
 Share

×
×
  • Create New...