Jump to content
Corsair Community

ICUE dashboard flickering on monitor connected to IGPU


CoconutJones
 Share

Recommended Posts

so i wanted to have my second and eventually third monitors connected to the Internal GPU on my 9900k so my NVIDIA GPU could handle my primary monitor exclusively but when i plugged it into the HDMI port on my motherboard the ICUE dashboard flickers like crazy and overtime makes all the monitors go black for moment till they reset a few seconds latter

 

i tried different drives from Intel and it seems to keep happening regardless of the driver and even tried a different monitor then the second one I'm using and it was doing it on that one as well but it works fine when plugged into the another port on the discrete GPU. I'm not sure if its ICUE acting weird or if my IGPU might be slightly messed up ( it doesn't seem to freak out with anything else being used on it tho)

 

any help would be appreciated

Link to comment
Share on other sites

Hmmmm ... sound like an issue with OpenGL - iCUE uses that for rendering.

I've run iCUE on an Intel iGPU - 7700K - (my server only has the iGPU) and iCUE has been fine. I wonder if it's some confusing switching between GPUs for the OpenGL rendering??

Link to comment
Share on other sites

hummm, so after installing some new drivers and such from my motherboard manufactuer the flickering has stooped but it still randomly will freeze up and make all the displays reset. i tried to find some Open GL drivers to download but im having trouble finding them to potentially fix the issue
Link to comment
Share on other sites

  • 6 months later...
 Share

×
×
  • Create New...