Jump to content
Corsair Community

Corsair H100i V2 not being picked up by link or Icue


Nefti
 Share

Recommended Posts

Hey,

 

I've had my setup for about 1 year and I've suddenly noticed that my H100i V2 led wasn't lighting up anymore.

 

I started looking into this matter and I found out that neither Corsair Link or Icue were picking up the H100i V2.

 

After a bunch of digging and going through the forums I've done about all I currently can:

 

- changing the CPU fan speed in the bios so the pump gets the 12V of power it needs.

- seeing if its being detected by using USBDeview (it did show up this morning but it doesnt now)

- Tried using different hubs on the MOBO

- Tried using different cable.

- Reinstalled all software.

 

The led light actually does turn on but for a split second after which it gives of a faint green/white- ish glow.

 

It does this light flickering thing for my CPU FAN header, AIO pump header and CPU OPT header.

 

I'm also currently using the commander node pro and a lightning node pro in combination to power/ control 5 fans (my cpu fans arent connected to the aio pump connectors but to the lightning node pro).

 

Please help a person thats near despair!

 

Nefti

Link to comment
Share on other sites

 Share

×
×
  • Create New...