Jump to content
Corsair Community

Perfect Case LED integration - Commander Pro


Recommended Posts

Hi,

 

I create this topic about my RGB LED case integration.

 

/!\

Note

For moderator, i have limitation of ten photos.. crazy :eek: can you increment this limitation ?

For User: think to remove space before .gl/ URL ...

/!\

 

 

First, The case

* Phanteks - Eclipse P400S

 

This case are sending with :

* RGB LED Strip with magnet

* RGB LED Strip on front

* RGB LED on Power Button

On top of case we have button to switch styles/colors.

 

I recently buy the Corsair Commander Pro to connect Fan/Future Addressable LED Strip. Addressable because Commander Pro doesn't support RBG LED.

 

Second, LEDs

Commander Pro have the following LED pinout :

* +5; Data; GND

Standard RGB LED have the following LED pinout :

* +12; -G; -B; -R

attachment.php?attachmentid=35888&d=1560896368

 

Thirdly, The DAC

DAC Converter is needed to transform Data signal to Analogique Voltage.

Commander Pro is compatible with cheap WS2812B LED Strip, so we use only chip to transcode signal.

 

I found on ebay a reseller we sells bord with :

* WS2811 Chip

* +5; Data; GND Input

* +5; Data; GND Output

* +12; -G; -B; -R Output

It's look like this :

https://photos.app.goo .gl/HfvSDNsrA5jeUjiK8

 

Fourth, The POC

To test the compatibility of *WS2811* chip, i made POC :

 

attachment.php?attachmentid=35896&stc=1&d=1560897030

Grey: +12V (Ext. Supply)

Blue: GND (Ext. Supply)

Red: Data (Connected to the second pin of second Commander Pro LED connector)

 

attachment.php?attachmentid=35895&stc=1&d=1560897030

Orange: -Green

Brown: -Blue

Red: -Red

Yellow: +12v

 

Fifth, The TEST

https://photos.app.goo .gl/u5rLepJYtpA6WVb4A

-> During the POC, +12v on board doesn't work properly, so i connect the yellow to +12v bord input directly.

 

I have successfully power up and running LED Strip with the DAC and Commander Pro :

https://photos.app.goo .gl/mzKxRHSpBijZTN3t5

 

Sixth, Make IT!

POC Is good but not for production of course.

 

Like you see on my video, i have three LED. One on top with button to change color.

For my integration, i use original connector :

Original :

attachment.php?attachmentid=35893&d=1560896404

Cut :

attachment.php?attachmentid=35894&stc=1&d=1560897030

 

Pinout :

https://photos.app.goo .gl/tQREa6W2okEieVEB7

 

Finaly :

attachment.php?attachmentid=35889&stc=1&d=1560896958

-> +12v on board doesn't work properly, so i connect the yellow to +12v bord input directly.

 

Sixth, the reassembly

 

https://photos.app.goo .gl/LshCqmiofckuzD3d8

Connect the Power Button LED, Case LED Strip, and Bottom Case LED.

Try :

https://photos.app.goo .gl/Ubd8KBmfZv2otQbh7

-> I connect 4 bords, 1 extra if i need to connect one more RGB LED.

 

It's working very fine.

Last jobs : make good connector for the Commander Pro Data Output :

https://photos.app.goo .gl/KpVN3SGQXrrrgNGC8

 

 

look at my beautiful support :D:

attachment.php?attachmentid=35897&stc=1&d=1560897030

 

 

Sorry for my english :)

This is the link of full photos/vidéos library :

library

 

Bye!

-- Vincs94

POWER_BTN.thumb.JPG.e82899754d5ea4bfbac7bce8453598a9.JPG

PROD.4.thumb.JPG.9bd9d56a99187ade188c77a206ab5602.JPG

PROD.3.thumb.JPG.3ce2766eea6b1dc94ca836e869fa0133.JPG

PROD.2.thumb.JPG.1da8d9b57b533200aa6bf8bcd4355717.JPG

PROD.1.thumb.JPG.14748e5d4980000b7f928413cb867ced.JPG

TOP.ORIGINAL.thumb.JPG.b7c21b9173b735360ca3a188fc3347b5.JPG

TOP_CUT.thumb.JPG.4350c60a2c5b41d6882a3d8b69afc5f6.JPG

POC.2.thumb.JPG.430720ea276868410115a9d7d06c4dd0.JPG

POC.1.thumb.JPG.49f94c7b03001a470a54b2e4e79cd0f6.JPG

PROD.6.thumb.JPG.1f0267340a45ae32380062416144bbe1.JPG

Edited by Vincs94
Link to comment
Share on other sites

 Share

×
×
  • Create New...