Jump to content
Corsair Community

RGB LL Fans Glitching and flashing


jalzoo
 Share

Recommended Posts

My LL120 RGB fans have started glitching and flashing. Not a constant flash just every now and then. I also notice that my top fan out of the 3 i have on the front doesn't seem to be in sync with the rest. I have tried switching the fans round to see if any are faulty and still does the same thing. I remember updating iCUE and i assume that is where the problem came from but i cant be sure. I am using a commander pro with the LED hub. So far i have tried Everything complete uninstall but still the same.

 

Does anyone have any ideas on how to sort this out. Ive lost patience trying to fix it lol :mad:

 

Thanks

Link to comment
Share on other sites

I had the same issue. It's most likely due to a defect fan. I suggest you try find the particular fan(and/or the fan in front of that one) that is glitching and place it on the of the lighting hub and see if the glitch is at the end of the loop.

 

I had to replace 7 fans in total. I have no idea why or how it happened. As I never pulled on any cable and they were all brand new.

Link to comment
Share on other sites

I had the same issue. It's most likely due to a defect fan. I suggest you try find the particular fan(and/or the fan in front of that one) that is glitching and place it on the of the lighting hub and see if the glitch is at the end of the loop.

 

I had to replace 7 fans in total. I have no idea why or how it happened. As I never pulled on any cable and they were all brand new.

 

Thankyou!!, I have been ripping my hair out for ages trying to work it out. I checked my cue fan control and noticed there was one fan that i had no control of so i checked it and also noticed that the fan was more dull than the others. Luckily i had some spare LL fans and swapped it out. Now we are back to RGB goodness with no flashing or flickering :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...