Jump to content
Corsair Community

iCUE Hydro X Profile Options Missing


falcon7370
 Share

Recommended Posts

Is a lighting channel configured on the the Commander Pro as HydroX?

Do you have existing fan curves for the CoPro as well?

 

Currently, my GPU, CPU, and pump are daisy chained and connected to a Lighting Node Pro, along with another RGB hub. The lighting node pro has a channel configured for Hydro X and I can control all RGB lighting.

 

I have all of my fans and the pump PWM, along with an additional RGB hub connected directly to the CoPro. The only fan curves that are available to me in CoPro are the defaults (Quiet, Balanced and Extreme).

Link to comment
Share on other sites

So I tried to create a 'dummy' Hydro X lighting channel on the commander pro and that didn't seem to work. I'm guessing it absolutely has to plug into the commander pro? My temperature probe is plugged into the first temperature sensor port.

 

EDIT: If that's the case, currently this is not possible for me. The RGB cables on the waterblocks and pump are incredibly short and don't reach the commander pro in my case. Having them reach a lighting node pro is easy because of how small the node pro is. Any thoughts? I saw that you can get custom made RGB fan extension cables but since these are 3 pin , I wasn't sure what my options were.

Edited by falcon7370
Link to comment
Share on other sites

I've also noticed that the custom curves don't appear if you have any custom fan curves with the Commander Pro.

 

As for the RGB extensions - how long do you need? If you have RGB Strips, they come with extensions that would work.

Link to comment
Share on other sites

I did have 1 custom curve when I tried creating a dummy Hydro X lighting channel. I will try deleting it and attempt that again . Is this a known issue with iCUE? Seems like the stars have to align for these Hydro curves to appear.

 

I do not have the LED kit. I did see the extensions there though and I think they will work. It just sucks having to spend 40 dollars potentially just to get 1 extension cable.

Link to comment
Share on other sites

I did have 1 custom curve when I tried creating a dummy Hydro X lighting channel. I will try deleting it and attempt that again . Is this a known issue with iCUE? Seems like the stars have to align for these Hydro curves to appear.

I have reported it. I'm considering doing a little script that'll just inject them into an existing configuration file. It's not that difficult if you are comfortable with XML and you know where to dig around.

 

I do not have the LED kit. I did see the extensions there though and I think they will work. It just sucks having to spend 40 dollars potentially just to get 1 extension cable.

Which extension cable is that? Where do you live? And how long do you need?

Link to comment
Share on other sites

I have reported it. I'm considering doing a little script that'll just inject them into an existing configuration file. It's not that difficult if you are comfortable with XML and you know where to dig around.

 

Which extension cable is that? Where do you live? And how long do you need?

 

That would be pretty useful. I'm a software developer myself so I'm pretty familiar with XML.

 

The extension cable I'm seeing that should work comes with the Corsair RGB LED Lighting PRO Expansion Kit, as it seems I will need a male to female 3-pin RGB extension cable that's included for the RGB strips to make the HydroX pump RGB cable reach my CoPro (everything else is daisy chained off of my pump).

 

I'm thinking 30cm to be safe. I currently live in Ohio (USA).

Link to comment
Share on other sites

  • 3 months later...

Any update on this?

 

I just got my custom loop finished with all Hydro X components and I am not seeing any Hydro X Performance profiles available in iCUE for the Commander Pro (only the defaults of Quiet, Balanced, and Extreme).

 

I also have my Hydro X LED components plugged into a Lighting Node Pro due to the short length of the cables, but my XD5+XG7 are daisy chained on one of the Node Pro ports and the other port is the XC7.

 

I have it configured properly for the lighting channels for the Node Pro, and also have the XD5 temp sensor plugged into the temp 1 channel, and the PWM for the XD5 is in port 6 of the PWM ports.

 

Any help on this would be greatly appreciated. I don't seem to have the cable length to connect the XD5+XG7 to the Commander Pro directly.

Link to comment
Share on other sites

You don't have to daisy chain them if you have the RGB channels available. The only difference might be when I set a preset lighting effect, the daisy chained ones automatically go in sequence with each other Your stray XC7 may have its own orbit. That may be of no concern at all, just FYI.

 

As for the missing Hydro curves, try restarting the service from the settings menu. Every now and then when I reset up iCUE from scratch it isn't there the first time. If the easy way does not work, you can quit iCUE and the Corsair Service in the task manager, then go C:Users/(name)/app data (hidden)/Roaming/Corsair/CUE/Cooling and delete the congfig file in that folder. Then restart iCUE. This has forced a reload in the past. Be aware this will wipe any custom curves you have already made, so the safer option is to cut and paste it to the desktop if you are trying to save those and this does not work.

Link to comment
Share on other sites

  • 4 weeks later...
I'm having the same issue as Spartanco regarding the Hydro X Performance options not appearing. I just tried c-attacks suggestions and none worked at bringing the options up. Without iCUE recognition of the pump for what it is, it refuses to move more than a trickle of fluid at a time
Link to comment
Share on other sites

I'm having the same issue as Spartanco regarding the Hydro X Performance options not appearing. I just tried c-attacks suggestions and none worked at bringing the options up. Without iCUE recognition of the pump for what it is, it refuses to move more than a trickle of fluid at a time

 

First, set the fan port for the pump to 4-pin/PWM. Then you can set a custom curve for it. If you want, the settings for the default HydroX Pump Curve are in the HydroX FAQ: https://forum.corsair.com/v3/showthread.php?t=188181.

Link to comment
Share on other sites

 Share

×
×
  • Create New...