Jump to content
Corsair Community

K83 Wireless update problem


peL
 Share

Recommended Posts

Hey, i just got my new k83 wireless keyboard and notice it has firmware v. 3.13. When attempting to update to v. 3.19 i run into a problem.

 

Following the steps given, as you can see in the picture attached, will just leave me going in a loop not able to start the update. Even tried many different variation of the ritual.. But when i unplug the keyboard it aborts the update.

My iCUE is up to date (v. 3.16.56). Any suggestions? :rolleyes:

 

update.png.1d433eef32bba95d7aabf853acabe14c.png

Link to comment
Share on other sites

Attached the cable to a usb port directly to motherboard and it was ok. :roll:

 

 

Edit: Not really fixed.. Update started but cant get past 47% ..

Edited by peL
Link to comment
Share on other sites

  • 4 months later...
Having the same issue. bought the keyboard from a show event. Been having a few on and off issues with recognition but the major one is that it won't update to the latest firmware. It sticks at 47% no matter which USB port I use and factory reset doesn't seem to do anything
Link to comment
Share on other sites

  • 3 weeks later...

Similar problem for me, Following all the steps the update never start, any suggestion from corsair?

 

Ok, finally I succeed to update the keyboard, but I had to update iCue first to latest version, then start the update, the update stopped at 97% asking me to unplug the usb cable, unplug and replug the usb receiver, power on the keyboard but now the keyboard went useless, unable to connect again to the receiver, I had to restart the PC (that hanged on stop) at the reboot the keyboard was FINALLY updated.

 

No words...

Edited by canapi
Link to comment
Share on other sites

  • 1 month later...
  • 6 months later...

Hey I got this keyboard back in late march. was working okay till tried to do an firmware update. ever since then this keyboard crashes ICUE. I've tried to factory reset it. and I have no idea if that worked. but still continues to crash ICUE.

 

posting this here cause I'm unsure if its related to a corrupted firmware update or other.

Link to comment
Share on other sites

 Share

×
×
  • Create New...