Jump to content
Corsair Community

iCUE crashing and not responding


Archspy
 Share

Recommended Posts

Hi,

 

I've used iCUE for now couple of months and everything was doing fine.

 

But recently the program just started to act strangely, when I open it, it opens but after that as soon as I click anywhere it's lagging and (stop responding), if I wait like 2-3 mins it does the command I asked but as soon as I try anything else it does it again. Sometimes it just doesn't respond and end up crashing.

 

I tried to uninstall and reinstall a clean version but it keeps doing it.

 

Any ideas ?

 

Thanks

Link to comment
Share on other sites

  • Corsair Employees

Because the software is crashing, this probably means that Windows is generating an error report. This is an often a great tool for tracing the cause of an issue.

 

Please perform the following steps:

 

1. Recreate the crash.

2. Go to the Event Viewer within Windows (Start > run > eventvwr.msc)

3. Navigate to Windows Logs > Application, and then find the latest event with “Error” in the Level column and “Application Error” in the Source column.

 

Please copy the text on the General Tab and send it to us so we can look into this issue.

Link to comment
Share on other sites

Error 1 - .NET Runtime

Application: Corsair.Service.CpuIdRemote64.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.AccessViolationException

at CpuIdWrapper.Sdk.CpuIdSdk.RefreshInformation()

at CorsairLink4.Service.CpuIdRemote.CpuIdRemoteService.RefreshInformation()

at DynamicClass.SyncInvokeRefreshInformation(System.Object, System.Object[], System.Object[])

at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(System.Object, System.Object[], System.Object[] ByRef)

at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(System.ServiceModel.Dispatcher.MessageRpc ByRef)

at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(System.ServiceModel.Dispatcher.MessageRpc ByRef)

at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(System.ServiceModel.Dispatcher.MessageRpc ByRef)

at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean)

at System.ServiceModel.Dispatcher.ChannelHandler.DispatchAndReleasePump(System.ServiceModel.Channels.RequestContext, Boolean, System.ServiceModel.OperationContext)

at System.ServiceModel.Dispatcher.ChannelHandler.HandleRequest(System.ServiceModel.Channels.RequestContext, System.ServiceModel.OperationContext)

at System.ServiceModel.Dispatcher.ChannelHandler.AsyncMessagePump(System.IAsyncResult)

at System.ServiceModel.Dispatcher.ChannelHandler.OnAsyncReceiveComplete(System.IAsyncResult)

at System.Runtime.Fx+AsyncThunk.UnhandledExceptionFrame(System.IAsyncResult)

at System.Runtime.AsyncResult.Complete(Boolean)

at System.ServiceModel.Channels.TransportDuplexSessionChannel+TryReceiveAsyncResult.OnReceive(System.IAsyncResult)

at System.Runtime.Fx+AsyncThunk.UnhandledExceptionFrame(System.IAsyncResult)

at System.Runtime.AsyncResult.Complete(Boolean)

at System.ServiceModel.Channels.SynchronizedMessageSource+ReceiveAsyncResult.OnReceiveComplete(System.Object)

at System.ServiceModel.Channels.SessionConnectionReader.OnAsyncReadComplete(System.Object)

at System.Runtime.Fx+AsyncThunk.UnhandledExceptionFrame(System.IAsyncResult)

at System.Net.LazyAsyncResult.Complete(IntPtr)

at System.Net.LazyAsyncResult.ProtectedInvokeCallback(System.Object, IntPtr)

at System.Net.Security.NegotiateStream.ProcessFrameBody(Int32, Byte[], Int32, Int32, System.Net.AsyncProtocolRequest)

at System.Net.Security.NegotiateStream.ReadCallback(System.Net.AsyncProtocolRequest)

at System.Net.AsyncProtocolRequest.CompleteRequest(Int32)

at System.Net.FixedSizeReader.CheckCompletionBeforeNextRead(Int32)

at System.Net.FixedSizeReader.ReadCallback(System.IAsyncResult)

at System.Runtime.AsyncResult.Complete(Boolean)

at System.ServiceModel.Channels.ConnectionStream+IOAsyncResult.OnAsyncIOComplete(System.Object)

at System.ServiceModel.Channels.PipeConnection.OnAsyncReadComplete(Boolean, Int32, Int32)

at System.ServiceModel.Channels.OverlappedContext.CompleteCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)

at System.Runtime.Fx+IOCompletionThunk.UnhandledExceptionFrame(UInt32, UInt32, System.Threading.NativeOverlapped*)

at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)

 

 

Error 2 - Application Error

Faulting application name: Corsair.Service.CpuIdRemote64.exe, version: 3.16.0.4, time stamp: 0x5ccace14

Faulting module name: cpuidsdk64.dll, version: 1.2.1.6, time stamp: 0x5c2e4d8a

Exception code: 0xc0000005

Fault offset: 0x00000000000a7ba9

Faulting process id: 0x2554

Faulting application start time: 0x01d51c78ded8f52d

Faulting application path: C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\Corsair.Service.CpuIdRemote64.exe

Faulting module path: C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\cpuidsdk64.dll

Report Id: 9c68e737-c0bf-4678-a86d-996f0c41fb6e

Faulting package full name:

Faulting package-relative application ID:

 

Information - Windows Error Reporting

Fault bucket 1944149307206671331, type 4

Event Name: APPCRASH

Response: Not available

Cab Id: 0

 

Problem signature:

P1: Corsair.Service.CpuIdRemote64.exe

P2: 3.16.0.4

P3: 5ccace14

P4: cpuidsdk64.dll

P5: 1.2.1.6

P6: 5c2e4d8a

P7: c0000005

P8: 00000000000a7ba9

P9:

P10:

 

Attached files:

\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERE2D9.tmp.dmp

\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERE413.tmp.WERInternalMetadata.xml

\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERE423.tmp.xml

\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERE421.tmp.csv

\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERE441.tmp.txt

 

These files may be available here:

C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Corsair.Service._e4fa5aa824fe9dee6d2f2b7ed5c9e07ea292537d_23343718_1fb8e615

 

Analysis symbol:

Rechecking for solution: 0

Report Id: 9c68e737-c0bf-4678-a86d-996f0c41fb6e

Report Status: 268435456

Hashed bucket: 55e993e86a02dcbbaafb017e8e601be3

Edited by Archspy
Link to comment
Share on other sites

So guys, any news ?

 

My iCUE is unusable as it is, I have to wait 2 min for each command I want to do !!

 

I tried to uninstall, fresh install, everything I though and it still does that, could it be related to faulty profiles ?

 

I even tried to run program in safe mode and it does exactly the same !

 

EDIT:

Ok I also tried to install an older version of iCUE CorsairUtilityEngineSetup_3.1.133_release

and it does the same thing.

Edited by Archspy
Link to comment
Share on other sites

The error is in the CPUID monitoring service - this monitors things like CPU temps and the like. Depending on what you are running - which we can't tell because you've not specified - this may be unnecessary. Try renaming the CPUIDSDK dlls to something like CPUIDSDK.dll.bak. Note that there are two of them.
Link to comment
Share on other sites

I renamed files:

 

Corsair.Service.CpuIdRemote.exe

Corsair.Service.CpuIdRemote64.exe

cpuidsdk.dll

cpuidsdk64.dll

 

to

 

Corsair.Service.CpuIdRemote.exe.bak

Corsair.Service.CpuIdRemote64.exe.bak

cpuidsdk.dll.bak

cpuidsdk64.dll.bak

 

restarted program and it still does the same (Not responding) thing but it didn't crashe again yet.

 

I tend to think it's related to profiles as it's mainly when switching/editing profiles that it freezes, or when creating new actions, etc.

Though I tried with no profiles (only default one) and it still freezes....

Link to comment
Share on other sites

 Share

×
×
  • Create New...