Jump to content
Corsair Community

K95 RGB issue when using USB 3.0


DHoff365
 Share

Recommended Posts

I have had an issue with my K95 RGB, but have found a work around, and I wanted to post it here, and see what others might think, or if the devs and product specialists have any input. Like I said, I've found an acceptable work-around, but I just wanted to mention it.

 

My hardware specs are currently up to date in my profile. I'm running Windows 10 Pro 64-bit, build 1903. As of the time of writing, iCUE is up to date, as is all the firmware for all my Corsair devices. I also have a Dark Core RGB mouse, a Commander PRo, Lighting node Pro with 4 strips, 6 HD140 fans, and an HD150i Pro.

 

The problem is, that when I use the single port connectivity on a USB 3.0 port, iCUE doesn't pick up the keyboard, and profile activation and color switching does not happen. Device manager shows the input device in a problematic state. I can correct this by doing one of two things. I can click on and disable the hardware on the device list, and then re-enable it, then iCUE will pick it up and switch colors, or I can do the same thing by physically unplugging and re-plugging the keyboard from the back of the PC. This happens when iCUE starts automatically. I have not tried manual activation of the software.

 

The work-around i have found, is to plug both plugs into the USB 2.0 ports as per the instructions, and iCUE picks it up normally at startup.

 

There isn't so much data running through the keyboard where I need to have it running on a 3.0 port, but it'd be nice to consolidate a little bit.

 

I don't know if anyone else is having this issue, but that's my $0.02.

 

Thanks for reading, and have a great day!

Link to comment
Share on other sites

  • Corsair Employees
So this generally happens because of the USB ports on the PC having out of spec sleep states. It's just not booting the keyboard fully during the initial boot phase. Either that, or iCUE's not enumerating it correctly when the computer boots because something else is enumerating the USB at the same time. The easiest workaround is just turning on iCUE manually. Alternatively, you can turn off Windows Fast Boot, which will actually turn the USB off when the computer is powered down.
Link to comment
Share on other sites

 Share

×
×
  • Create New...