Jump to content
Corsair Community

Corsair IronClaw RGB Wireless - DPI problems


Calvins
 Share

Recommended Posts

The brightness setting is under the master "Settings" menu at the very top, then click on the ICW icon. You also can do it by adjusting specific color brightness if you are looking for a more tailored approach.

 

Perhaps some screen shots as suggested above?

Link to comment
Share on other sites

  • 3 weeks later...

Yeah, even new firmware for mouse (0.11.80) and dongle (0.9.40) not resolving dpi issues

 

The brightness setting is under the master "Settings" menu at the very top, then click on the ICW icon. You also can do it by adjusting specific color brightness if you are looking for a more tailored approach

Brightness slider works for my K65 keyboard, but for mouse there is only one level, like on or off

Link to comment
Share on other sites

I have the same issue :[pouts:

 

Which issue? Brightness? Or remapping buttons? Be specific with what you are trying to remap since this does not appear to be common.

 

 

Brightness slider works for my K65 keyboard, but for mouse there is only one level, like on or off

 

I definitely have the standard 0/3 "off", 1/3, 2/3, and 3/3 full brightness slider positions in the settings. Perhaps another sign the iCUE installation is corrupted.

Link to comment
Share on other sites

I'm having this same exact issue and getting Corsair to respond in a decent timely manner is a nightmare. They took over a week to message me back then told me to soft reset the mouse which did not even work.

 

I'm having this same DPI issue with the split triggers, makes them totally useless.

 

I'm also having an issue where my IronClaw RGB Wireless will not update and fails every single time.

 

Have tried uninstalling iCUE several times. Erasing trace evidence of iCUE in the registry as well. Still does the same thing. Loosing hope might make a brand switch if I cant get these issues resolved.

Link to comment
Share on other sites

The same, but I updated my mouse from another PC. Maybe a issue with USB ports

 

I have since been able to update my mouse finally. I had to system restore my PC to a month ago. Then reinstall iCUE and it worked, however in the process of system restore it fried my graphics drivers and I had to do a full DDU wipe of my graphics drivers and fresh install...

 

Still having the DPI up and down issue where the split triggers retain DPI up and down functions even though I have remapped them over and over trying everything.

 

This seriously needs a fix. Who the hell put the DPI up and down as standard keys for the split triggers to begin with.....

Link to comment
Share on other sites

Bump, do any admins ever post in Corsair forums on problems? Really would like a fix for this.

 

There's a post by Corsair Calico Jack in this very thread. I guess you didn't read it. If you need to, try PMing the reps, as of late they are extremely backed up.

Link to comment
Share on other sites

  • 3 weeks later...
I just bought the IronClaw wireless mouse approx 3 weeks ago, I like the feel & button positions, BUT... I'm also having the same issues as others with the remapping of the DPI up & DPI down buttons, I remap as I have done multiple times, the dpi up & down buttons are the only ones giving me Constant issues, even when remapped they still adjust my DPI to either way too fast or far too slow, I have made sure the "Retain original key output" option is Unchecked, have the latest firmware (checked multiple times), icue up to date, have soft reset the mouse, tried it via 2.4ghz & plugged in, all to no avail, is there a fix I don't know of other than just returning the mouse & using my steel series one instead, I have other corsair products & would prefer to stick to 1 brand, but not unless this issue can be sorted...anyone know of any kind of solution ? Edited by Disturbed7
Link to comment
Share on other sites

  • 3 weeks later...
I'm having this same exact issue and getting Corsair to respond in a decent timely manner is a nightmare. They took over a week to message me back then told me to soft reset the mouse which did not even work.

 

I'm having this same DPI issue with the split triggers, makes them totally useless.

 

I'm also having an issue where my IronClaw RGB Wireless will not update and fails every single time.

 

Have tried uninstalling iCUE several times. Erasing trace evidence of iCUE in the registry as well. Still does the same thing. Loosing hope might make a brand switch if I cant get these issues resolved.

 

Try rebooting into windows safe mode with networking and then update. Worked for me, possibly a driver conflict of some sort.

Link to comment
Share on other sites

Little bit about my setup;

 

I am actually planning to use the mice on my MacBook. However, I have also virtual windows, so I tired this issue on both by resetting the mouse, and installing the firmware again and again.

 

This issue shows up on bluetooth mode. Because system doest need hardware profile during wired or wireless mode, I believe (I have the mouse for two days, I might be wrong)

 

I setup 3 hardware profiles, and zero local profiles. This is nothing to do with issue, just information. I am setting up a very simple setup just localize the issue.

 

I am going to setup DPI change buttons that is why I setup new DPI profiles and assign them as default for those profiles.

 

Action buttons ( This is the issue)

DPI Up - Copy action

DPI Down - Paste action

Option button - Select all

 

LED profiles not affecting the issue

 

My DPI profiles are

Slow 1000 DPI

Medium 2500 DPI

Fast 5000 DPI, and I am using %50 acceleration. This is also nothing to do with the issue.

 

My profiles completely, identical except DPI setting and how I default them

 

Slow profile default Slow DPI 1000

Medium profile default Medium DPI 2500

Fast DPI default Fast DPI 5000

 

After 4 -5 hours attempt, I first though it is not recording the profile correctly. However I believe issue is not having a DPI change button.

 

When you change the profile with profile change button, firmware assigns the dpi randomly or can't assign correctly. Or because DPI profiles are not associated with your actual profiles, system doesn't clean them when you clean your hardware profile. They are stuck there forever, until you manually trigger them from mice itself.

 

One thing I didn't understand, why DPI profiles are tide to all the profiles, or another way all profiles are sharing the same DPI profiles as well. If I am correct this doesn't make any sense, because if I have a profile ,this profile should have a unique set of dpi profiles. However that doesn't seems working correctly.

 

To work around that I assigned the middle button to DPI Trigger.

 

After adding the DPI Trigger to middle button, when you change your profile, you can assign the correct DPI back in to the active profile. This time firmware somehow correctly records your selection. When next time you toggle your profile it selects the correct DPI.

 

I hope my observations are correct, and this helps to you and the corsair team.

 

Thanks for reading.

Link to comment
Share on other sites

  • 1 month later...
 Share

×
×
  • Create New...