Jump to content
Corsair Community

Corsair ll120 fans and rgb hub


joeylai123
 Share

Recommended Posts

LL120 fans stopped lighting up....plugged all fans one by one into fan port 1 on rgb hub and they all light up fine....the only way i can get them all to work is if i put fan 1 into port 6, fan 6 into port 3 and fan 3 into port 1....of course now the sequence is all wrong...what can this mean? i purchased a brand new rgb hub and the same issue is there so i have no idea what the problem can be?

also fans were working fine until i updated to latest 3.16.56 then 2 went off...tried older versions no luck

Link to comment
Share on other sites

Likely a misbehaving fan. The fans operate in series - 1 fan passes the signal on to the next. So having a fan light up by itself in port #1 is only half the story - you also need to check if a known good fan lights up in port 2.
Link to comment
Share on other sites

I'm in agreement with DevBiker, one of your fans seems to be busted, or there is a short or a partially sheered cable that is coming loose and then making its proper electrical contacts once again as you reposition the fan. Test with a single fan at a time and work down the list of controller ports (for all LED AND power ports, make sure you do try the other LED channel too if you are using a Lighting Node Pro, which is the ONLY RGB controller apart from a Commander Pro that you should use with LL series fans. The regular RGB fan hub that comes with older model fans will not support higher end effects. Once you have confirmed that the ports all work for a fan, carefully inspect the wire leads for the PWM (power) and 4-pin RGB that lead from the fan to their appropriate destinations, pay especially close attention to areas where the lines could snag on things like the edges of your PCI-E cards, PSU shroud, or thumb screws for case mounts as these tend to get caught up and possibly damaged during an install. Even if a cable is partially nicked, it could be just enough that the connectivity becomes servered just by flexing the damaged are of the cable. Eventually, you will find the problem fan/cable and then you'll need to do a repair or a return depending on your warranty status for the fans. Good luck!
Link to comment
Share on other sites

 Share

×
×
  • Create New...