Jump to content
Corsair Community

Scimitar pro RGB (yellow) malfunction issues

Recommended Posts

Hi all as stated above I have scimitar pro, I've had it about a year now without a fault although a few weeks ago it started having problems. It began by dropping my saved mapping for macro keys so i re installed ICUE and all was fine for about two days.


Two days have passed and i go to play some squad i feel like im getting lag but nothing around me seems to be affected i closed down squad and began to test my connection.


Whilst trying to open things my mouse freeze's then begins to move again and proceeds to do that for about 2-3 minutes before finally disconnecting all together and loosing power. Window's gives me a notification that the USB device had malfunctioned and is no longer recognized.


I have tried everything i could find on the matter all failed. A broken man i decided to do a fresh install hoping for the best. It WORKED! or so i thought roughly 30 minutes goes by and it begins. My mouse is slowly showing symptoms as before. Finally i decide to put a ticket in and the wait for the Firmware/reply begins!.


While i wait for the reply i thought i would create a thread on the topic and see if anyone else has had this problem. Any info that would hurry this process along would be much appreciated! i don't know how long i can go without Gaming!. :ummmm: :brick:


my logs seem to indicate something about the LED's being at fault but i dont know exactly what i am looking at. So I have attached the full zip file of my system info and logs.





Edited by Ghost_Endgame
Link to comment
Share on other sites

if anyone find's this thread and has the same problem in the future this is for you. i put in a ticket on the 23rd asking for the hard reset info was given an automated reply telling me to try a soft reset (had already said i tried it). it now being the 29th where i am i still have not had a reply....... disappointing.



so because they make it so hard to do a hard reset i was stuck for days i had read so many threads...... i decided i cant play without my MMO mouse i was going to look everywhere not just these forums........ nothing couldnt find anything relevant it seemed like no one had uploaded a base firmware file for a scimitar PRO.


I ended up on a thread i had read on the 23rd the one that told me i should save time and open a ticket. 2 posts below was the following post i will put below so far my mouse is working but it's only been about 10 minutes.



"Instructions sent to me by corsair for my Corsair Schmitar Pro RGB Model Code: CH-9304111


Note: I will not be held responsible if you further break your device by installing this firmware on the wrong mouse or you fail to follow the instructions below.


Firmware File: https://drive.google.com/file/d/1hwX...ew?usp=sharing


1: Unplug your mouse from the computer.

2: Locate the small pinhole underneath your mouse. For some, this will be located directly on the bottom in plain sight. On others, it will be located underneath one of the removable weights attached to the bottom of the mouse.

3: Using a small paperclip or push-pin, press down on the button inside the pinhole.

4: Plug your mouse back into the computer, while holding down the pinhole button.

5: Once it is plugged back in, your computer should recognize a drive called CRP_Disabled. Please open this.

6: Download the firmware file from the ticket. If it is compressed into a .RAR file, please extract this file to an easily found location on the computer.

7: Delete the file FIRMWARE.BIN from the CRP_DISABLED drive, and then place the file with ISP in it’s name to the CRP_Disabled drive.

8: Once you have performed the steps above, please unplug your mouse and then plug it back in. The device will then return to normal. Please test to see if the issue reappears. If it does, please inform us on the ticket for further troubleshooting."




Edited by Ghost_Endgame
Link to comment
Share on other sites

The Hard reset did not work for my le crap mouse found a picture of when i bought it the thing is only 8 months old and already had hardware failure just as i was about to change my razer keyboard i think it's a sign. my friends have also said they have had plenty of problems with their corsair product's i guess it's a common thing. hopefully customer support will get back to me on details for RMA'ing the mouse if it's miles away an will cost to much postage or take to long i think ill just take out the past 2 weeks of anger out on it with a hammer..... this mouse has literally broken my spirit if i could turn it into a being id smash the **** out of it i swear.
Link to comment
Share on other sites


  • Create New...