Jump to content
Corsair Community

iCUE v3.16.56 Patch Notes


Corsair James
 Share

Recommended Posts

  • Corsair Employees

Hi everyone,

 

Here are the official patch notes for iCUE v3.16.56.

 

Patch Notes for iCUE v3.16.56

 


  •  
  • Resolved an issue with Vengeance RGB LEDs not turning off properly when disabled
     
  • Resolved an minor issue with 1000D Lighting Channels displaying improperly
     
  • Resolved an issue with Vengeance RGB PRO box checkbox not displaying properly
     
  • Obsidian 1000D's Commander Pro now supports HydroX Lighting
     
  • Sleep Mode as an adjustable feature has been added to K63 Wireless in Settings
     
  • K63 Wireless default for LED Shutoff has been changed to 10 from 15 mins
     
  • Resolved an issue with Play on Pressed Key not triggering lighting properly
     
  • Resolved an issue with CORSAIR ONE and Lighting Library Effects
     
  • Resolved an issue with Type Lighting Key and Ripple not displaying properly when switched
  • Resolved other various minor bugs and issues

 

Known Issues:

  • Some users will experience custom fan curve data loss upon restart. We have identified the source of the issue but will need additional time to resolve. This will be complete by iCUE v3.17
  • Certain profiles may cause iCUE to crash during the import process. This is under investigation.

Link to comment
Share on other sites

Tip to manage the custom fan curve data loss - back up your current iCUE configuration by saving the contents of %AppData%\Corsair\CUE to a different folder - or zipping it. If you lose custom fan curves, close iCUE, restore over the existing folder and the start iCUE.

 

Closing iCUE before shutting down may help mitigate the issue.

Link to comment
Share on other sites

Update went fine here. All my data is retained.

 

I had a problem with the last version where somehow iCUE became really sluggish, you could see the animations playing real choppy. An iCUE restart solved it.

 

I'm gonna keep an eye and report about that regarding the new version.

Link to comment
Share on other sites

So here we are 2 years later and I still cannot use icue properly . Still no X79 support but im told icue isnt the only control program having this problem as NZXT Cam also no longer supports X79 due to the exact same issue with CPUID. So I get that now. Even though Ive just been lied to now for 2 years. Now I just have an on going issue with icue just causing cpu spikes all the time so I cant even use it without it draning my cpu. Whats even worse is neither of of these issue you acknoledge as a known issue even though I and other people have been screaming at you for 2 years to sort this. Im going to Computex on Sunday and I will make it well known just how bad this software is and just how little you care.

 

2 years?? Early access iCUE was released 2018-03-27...

Link to comment
Share on other sites

NZXT CAM and iCUE both have the same underlying problem - it's an issue with CPUIDSDK. There's a limit on what they can about it. You well know that Corsair has recognized the issue but, unfortunately, they can't fix it.
Link to comment
Share on other sites

Hello,

 

I would like to add that after I had installed Windows 10 1903, I had the fan curves issue like everyone else. But, I have forgot to tell you that my Corsair VOID Pro RGB Wireless doesn't work after installing iCUE or if I remember Windows 1903. I actually don't remember, but, it did not worked, so I had to connect it with USB and Force the FirmWare Upgrade.

 

I guess it's after having installed iCUE, because I had to reinstall to test if all my fans curves could be saved after a fresh reinstall with registry cleaning. So, I guess it's iCue that if bugging the whole thing. This is still an issue to add to the list.

 

 

Thank you for having read me.

Link to comment
Share on other sites

my LL120 fans off my 1000d commander pro still don't work properly. They are now fixed on Arc colour but no LED trail from Arc. If i restart corsair service all other fans restart apart from one line of 6 LL120 on the 1000d commander pro. The other 4 i have connected to 1000d commander pro restart ok.

 

I have a lighting node pro with LL140 and LED strip all working fine with Arc.

 

The last 2 updates have upset the lighting effect on my LL120 fans.

Link to comment
Share on other sites

I had this new version installed and noticed that the profile(balance) i set kept resetting itself to quiet after a fresh boot up the next morning. The same happened at least 3 times before i uninstall and went back to the last 2 version. No more random changing of profile after that.
Link to comment
Share on other sites

The stock fan speeds is likely due to the deleted fan curves bug mentioned above. A workaround/backup plan is also posted.

 

And we don't have enough information to begin to troubleshoot the H100. First, which H100 RGB are we talking about? There are several variations (v2, Pro, Platinum). Second, where is the USB cable plugged in? Do you have Fast Boot and Windows Fast Startup disabled? USB/Chipset drivers up to date (you can get them from Intel even if your mobo manufacturer no longer posts them).

Link to comment
Share on other sites

Hi , so with last iCUE updates I ran into issue were only 1 and half of 4 rgb strips would respond to the software changes , 2 and half off the strip are stuck on same rainbow color with no animation . when I create difirent profile or insta lightning changes happens only to part of it ( tried reinstalling the soft , chaning cables, difirent lightning nodes does same thing ) Sometimes when restarting the icue services it works but for few minutes, as well as works fine when playing games like Division 2 or Far CRY (all strips work fine and light up how the should ,probably because they use corsair Link in games) .

If anyone can help with an advice ,much apreciated

Link to comment
Share on other sites

http://downloads.corsair.com/Files/CUE/iCUESetup_3.15.101_release.msi

 

Or if you need to go back further try:

 

https://drivers.softpedia.com/dyn-search.php?search_term=icue

 

or change the numbers in the direct link to match the software version you want.

 

Thanks! The relief i feel not having to redo all my fans is great!

 

From now on i'll always check the patch notes before download, just like i do nvidia drivers.

Link to comment
Share on other sites

I just updated and now I cant seem to configure the "hardware lighting" setting without crashing the software each time. I can LOOK at it, but as soon as i access the drop-down to configure any new settings or try and change colors the whole program freezes and crashes.

 

some of the settings stick so it seems like the changes stick until you powercycle your PC and nothing is different.

 

im looking around to try and find a crash log but im coming up dry in the program folder. as far as microsoft can see:

 

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

- <System>

<Provider Name="Windows Error Reporting" />

<EventID Qualifiers="0">1001</EventID>

<Level>4</Level>

<Task>0</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2019-06-19T00:17:31.737988800Z" />

<EventRecordID>1132</EventRecordID>

<Channel>Application</Channel>

<Computer>PersonalGear-3</Computer>

<Security />

</System>

- <EventData>

<Data>1768803946511473381</Data>

<Data>1</Data>

<Data>APPCRASH</Data>

<Data>Not available</Data>

<Data>0</Data>

<Data>iCUE.exe</Data>

<Data>3.16.56.0</Data>

<Data>5cd2f74b</Data>

<Data>iCUE.exe</Data>

<Data>3.16.56.0</Data>

<Data>5cd2f74b</Data>

<Data>c0000005</Data>

<Data>0139e2f0</Data>

<Data />

<Data />

<Data>\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER5E84.tmp.dmp \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER6059.tmp.WERInternalMetadata.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER606A.tmp.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER606E.tmp.csv \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER609E.tmp.txt</Data>

<Data>\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_iCUE.exe_57ea8fa65180aa2819dddbc618d8d5811eba196_e88d88f1_ce80d139-865a-485f-a722-7adcefaaa35c</Data>

<Data />

<Data>0</Data>

<Data>253bf0b9-ab4e-4ddc-9171-0c636ea587d7</Data>

<Data>268435456</Data>

<Data>8e44928826419678888c0dd15d201ae5</Data>

<Data>0</Data>

</EventData>

</Event>

 

so its generally unhelpful because some of these hex values kind of only make sense to microsoft. the only thing i could really find that seems like it might be of some help is a fault offset:

 

Faulting application name: iCUE.exe, version: 3.16.56.0, time stamp: 0x5cd2f74b

Faulting module name: iCUE.exe, version: 3.16.56.0, time stamp: 0x5cd2f74b

Exception code: 0xc0000005

Fault offset: 0x0139e2f0

Faulting process id: 0x262c

Faulting application start time: 0x01d526342906b1ca

Faulting application path: C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\iCUE.exe

Faulting module path: C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\iCUE.exe

Report Id: 9c916cac-c61a-4976-a7fe-1ffd59627be6

Faulting package full name:

Faulting package-relative application ID:

 

when looking at the fault offset it says crashing might happen when you input a procedure that has more than 4000 characters. now the values may be arbitrary and not relevant since the context of that discovery was for SQL for windows server, but given how many config values this program handles it may have seen yet another configuration and pushed it past its "threshold."

 

but then again i know nothing about programming. hence why im here asking all you guys

 

thanks for any help

Link to comment
Share on other sites

 Share

×
×
  • Create New...