Jump to content
Corsair Community

[URGENT] (Sabre mouse) ICUE can't find mouse when I move it


Recommended Posts

Hello!

 

I have had a problem with the ICUE program not seeing my mouse on start up for a long time. It was fixed by repairing the driver. (Temporarily, meaning I have to do it on most start ups)

 

However, recently I got a new glitch, making the mouse completely un-useable! Everytime I move the mouse or lift it up the ICUE program does not detect the mouse, until a few seconds later when it finds it again.

 

Restarting does not help, I did not do any damage to it (it happened all of a sudden), I have tried changing the USB ports (yes they all work fine) and the ICUE program is fully updated.

 

I don't know what to do as this is my only mouse, and it is purely a software problem. (I know this as it doesn't turn off or anything if the program is uninstalled)

 

Hope someone can help!

Thank you!

 

Edit: I fixed it by uninstalling ICUE and reinstalling it, I will keep this up for anyone else, or to post any updates if it comes back!

 

Edit 2: It keeps happening, although it is a lot shorter and a lot less often (In other words, it just stops for a second, the RGB lights turn to default and then back to my normal program), but it still happens!

Edited by mrmasterdavid
Link to comment
Share on other sites

 Share

×
×
  • Create New...