Jump to content
Corsair Community

LL Fans RGB not working (as usual)


Clem074
 Share

Recommended Posts

Hello everyone !

 

I will do my best to not write a salty message here but I will need a lot of self control.

 

One year and a half, 2500 euros and not a single day with LL fans working correctly with the RGB. At first, can someone explain to me how it is possible to sold something that is not working for that period of time. Is it even legal ?

 

 

After a first replacement of a defective fan (led issue) and I'm sure it's not the last one (random red leds, some leds now don't light up but on the last fan so the others are safe), now I only have one single fan that is lightning up (number one).

 

I changed the order of the fans to the lightning node because I've learnt some thngs from my first defective fan and nothing change. All the leds are ok so it don't think it's that.

 

I removed iCue and nothing is changing at all.

 

Can someone explain to me how is it possible ?

 

I'm about to complain to customer support because I don't see what else can I do. I'm not a salty guy but I just want my pc running for what I paid for and one year and half after, many updates of icue after, this is worst than before.

 

I've a node linked to a commander.

 

Thank you and sorry, I just can't anymore.

Link to comment
Share on other sites

Did a couple of test now and this is what I have :

 

I have 6 LL fans on the lightning node.

Only the first one works.

 

if I put the fan n°2 on the port n°1 and the fan n°1 on the port n°2, the first and the second fan work.

 

Any idea ?

 

is it the software or my fans ?

Link to comment
Share on other sites

there was something with the first series of LL ?

Because I already have one I had to replace.

 

Now you're telling me that I've the replace the first one. And I have also led issues with the 6 one.

 

wtf

Edited by Clem074
Link to comment
Share on other sites

Well, based on what you've said, your original Fan #1 isn't passing the signal down to the rest of the fans. That right there will take the entire chain out.

So, yeah, it needs to be replaced or repaired (assuming that it can be repaired). Replacement is the easiest thing to do. This should be an easy RMA.

Link to comment
Share on other sites

  • Corsair Employees

We can certainly RMA the fan.

 

To be clear, there's no huge manufacturing issue. It's just a lot of LED's in one device. Like, if one of the LED's fails, it makes all of the lighting further down the chain stop working. We can easily RMA it through a ticket.

Link to comment
Share on other sites

Seems a bit strange to me because I already knew what you just said but here, all the led are working on this fan (not on the last one).

 

But I trust you guys, thanks !

 

How can I ask for a ticket ?

Link to comment
Share on other sites

Seems a bit strange to me because I already knew what you just said but here, all the led are working on this fan (not on the last one).

 

But I trust you guys, thanks !

 

How can I ask for a ticket ?

 

 

click 'Support Ticket System' at the top of this page buddy

Link to comment
Share on other sites

 Share

×
×
  • Create New...