Jump to content
Corsair Community

Incorrectly thinks its an American keyboard.


FlameDuck
 Share

Recommended Posts

So I updated my K95 RGB Platinum to firmware to 3.21.7168, and now it thinks its a US keyboard (In reality its Nordic). If youre wondering why this post doesnt have any apostrophies in it, its because thats one of the keys that no longer work, because along with the greater than sign.

 

I am using iCUE 3.15.101 if it makes a difference.

 

As you might imagine these are quite annoying keys to not have working.

 

Does anybody have any ideas on how to fix this? I saw someone in 2014 having a similar issue with a German keyboard, but no suggestions on how to fix it, and surely that issue would have been addressed by now?

 

If I wanted to pay 240 bucks for a keyboard that only worked 6 months, I wouldve bought another Razer Blackwidow Chroma.

Link to comment
Share on other sites

In iCUE, go to settings and select K95 Platinum. There should be a 'Current Layout' option. Its US by default, you should be able to change it.

Thanks for this suggestion. When I do this however, The choices I get are Russian, Chinese, Thailand etc. which all seem to be US syle 104 key layouts. The ND is a British style 105 key layout, which is not available from the drop down.

Link to comment
Share on other sites

Try doing a clean install of iCUE (uninstall, delete registry entries and reinstall).

 

If that does nothing, then open a support ticket with Corsair and they should be able to help you out.

Edited by StrangeGeek
Grammar.
Link to comment
Share on other sites

 Share

×
×
  • Create New...