Jump to content
Corsair Community

New Dark Core RGB SE


DavidPuddy
 Share

Recommended Posts

Hello All,

 

I'm having issues updating the firmware on new Dark Core RGB SE mouse.

 

If connected by USB cable, iCue says it has the latest firmware v3.35, however while wireless it says I need to update to v3.35 but every time I try to update, the warning message say it fails so every time I start iCue while wireless it asks if I want to update. I think the current wifi version is v3.22. I have tried everything. I even bought a second mouse but that one has other issues where the firmware version in iCue says v. ?. so this one may be completely borked.

 

Anyone else with similar issues? I've never had such problems while updating a firmware in my life.

 

Thanks.

Link to comment
Share on other sites

1) Make sure mouse is wired AND dongle is in

 

2) Probably the dongle is still on older firmware, thus the flash update request. Forcing an update should fix.

 

3) Try different ports, and don't use any on a hub.

 

Yes, tried all those, thanks.

 

I don't understand it. May try calling Corsair tomorrow.

Link to comment
Share on other sites

 Share

×
×
  • Create New...