Jump to content
Corsair Community

[SOLVED] Corsair Sabre RGB Disassembly - USB device not recognised


Miss_Jaxxy
 Share

Recommended Posts

Hi All,

 

I couldn't find a full disassembly walkthrough or solution for my error, so I'm uploading a noob-friendly guide to the solution I (eventually) found. Images uploaded to imgur.

 

It started with my mouse occassionally not working on startup, but would work once unplugged and plugged back in again. Then it just wouldn't recognise it at all.

 

No amount of driver/iCue/windows10 updates helped.

I found a forum post for a similar issue that suggested unplugging the USB passthrough, so I thought I'd try that. But that means taking apart the mouse.

 

  1. Unplug the mouse from your PC

  2. Remove the FOUR skids from the base of the mouse. Note: each skid has a small access point to begin lifting from (these are shown by blue arrows in the attached
    )

  3. Unscrew the FOUR torx screws from under the skids with a T6 screw driver (see
    )

  4. Remove the three top pieces. I found the two sides just fell off, however the center piece needed to be pushed forward (towards the wheel). The sides ARE held on by several small knotches on the base, so try pushing upwards if it's stiff.

  5. Follow the cable to locate the USB passthrough (see
    ). Should be a white connector with 5 wires running from it. Pop that bad boy out GENTLY.

  6. Whilst the passthrough is still UNPLUGGED, plug the main cable back into your PC. Then, gently plug the white passthrough back in. If it worked, the lights should turn on and the mouse should respond.

  7. Unplug the main cable from your PC, and reassemble the mouse. Note that the center piece has a small latch under the left click button (circled in
    )

1_remove_skids.jpg.5b00a2ab241af3035c1c9bb89856a4c1.jpg

2_screws.jpg.46eff5da64771e91b3c90517dc3a1bbf.jpg

3_unplug_usb_passthrough.jpg.74b0c63079582788d0780425864a25b2.jpg

4_inside_body.jpg.9f131366e1104000f9ff7d28667c9042.jpg

5_inside_center_cover.jpg.8f881c44c89c72dd02828f3ce5f5c811.jpg

error.png.7c9e7bbbd0a207e6b37e8e1883c03052.png

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...