Jump to content
Corsair Community

iCue 3.15.101 Causes Major Stutter in Division 2


ressonance
 Share

Recommended Posts

The good news is that the SDK effects seem to be working better now in game but the bad news is that it causes major stutter while panning the mouse in the game. Turning off the SDK effects on both iCue settings and in game has no effect. The only workaround at the moment seems to be to quit iCue completely.

 

iCue on:

[ame]

[/ame]

 

iCue off:

[ame]

[/ame]
Link to comment
Share on other sites

Try turning Gsync to Fullscreen only in the Nvidia Control Panel.

 

Well. I had the same issue, although much more subtle, in my borderless windowed Rocket League (G-sync monitor) and switching it to full screen fixed it..

 

Why is this? How did you know that was the issue? Why can I not play games in windowed without stuttering while I have iCue open?

 

I almost thought I was going crazy and it wasn't actually stuttering.. until I switched to full screen and saw it get smooth as butter.

Link to comment
Share on other sites

Are you using a Corsair mouse or wireless mouse, tried a different mouse? Maybe a polling rate issue?

 

I'm using a Logitech G903 and I do have Logitech G HUB installed and running but I've already tested this with G HUB enabled/disabled with iCue enabled but that didn't stop the stutters.

 

I noticed when having full hardware control on and the sdk it uses more cpu so it could be that

No other game suffers from this issue, and I have turned off the SDK to try and see if that would help, it didn't :( Also I've got a Ryzen 2700X with 8 cores and 16 threads, I doubt iCue alone could bog it down that much. I mean I can even game whilst transcoding videos to x265 and FPS drop is noticeable but not too severe.

 

Try turning Gsync to Fullscreen only in the Nvidia Control Panel.

My GSYNC is already on Fullscreen only and I play in exclusive fullscreen mode everytime (unless the game doesn't support it)

Link to comment
Share on other sites

  • Corsair Employees
Well. I had the same issue, although much more subtle, in my borderless windowed Rocket League (G-sync monitor) and switching it to full screen fixed it..

 

Why is this? How did you know that was the issue? Why can I not play games in windowed without stuttering while I have iCue open?

 

I almost thought I was going crazy and it wasn't actually stuttering.. until I switched to full screen and saw it get smooth as butter.

 

I was talking to someone in the office about this when I saw the post and they suggested it. The GUI SDK iCUE uses needs an update, that's basically it. You can also just close the iCUE window so it's running from the taskbar. But if you have it open then Gsync is trying to control iCUE as well which is playing with the framerate.

 

@ressonance

Can you make a ticket for it and upload your DXDIAG? We're probably going to want to take a closer look, but we aren't seeing the same thing here.

Link to comment
Share on other sites

@ressonance

Can you make a ticket for it and upload your DXDIAG? We're probably going to want to take a closer look, but we aren't seeing the same thing here.

 

Can do! And, if I submit a ticket will the support person know to redirect it to software instead of asking me to RMA my Commander Pro (like the last time I tried to submit a software bug)?

 

Edit: Ok done, TICKET #892475

Edited by ressonance
Link to comment
Share on other sites

  • Corsair Employees
Can do! And, if I submit a ticket will the support person know to redirect it to software instead of asking me to RMA my Commander Pro (like the last time I tried to submit a software bug)?

 

Edit: Ok done, TICKET #892475

 

Just link them the forum post in your ticket and say that the forum guy said to have it reported as a bug. They will do some stuff to get it entered and grab your info.

Link to comment
Share on other sites

  • 4 months later...
I'm using a Logitech G903 and I do have Logitech G HUB installed and running but I've already tested this with G HUB enabled/disabled with iCue enabled but that didn't stop the stutters.

 

 

No other game suffers from this issue, and I have turned off the SDK to try and see if that would help, it didn't :( Also I've got a Ryzen 2700X with 8 cores and 16 threads, I doubt iCue alone could bog it down that much. I mean I can even game whilst transcoding videos to x265 and FPS drop is noticeable but not too severe.

 

 

My GSYNC is already on Fullscreen only and I play in exclusive fullscreen mode everytime (unless the game doesn't support it)

 

I have the same issues as you. It's especially bad with division 2. Even worse infact. Other games are not affected. Turning mouse polling rate down to 250Mhz solves it. Or quitting icue solves it.

 

I can verify that it's a issue with https://zowie.benq.com/ja/support/mouse-rate-checker.html.

When icue is running the rate is 300-600hz.

Quitting icue it goes directly 1000hz.

 

I'm running Windows 10, latest icue (has been happening in the last 3 revisions of icue), 2950x/MSI MEG CREATION/32GB/970 Evo Mouse is M65. Have tried to different M65. Both have the same issue.

Link to comment
Share on other sites

 Share

×
×
  • Create New...