Jump to content
Corsair Community

Constant disconnects narrowed down to K95 Platinum


Gronar
 Share

Recommended Posts

Been getting the constant USB disconnect/reconnect sounds all day today and have finally narrowed it down to my K95 Platinum keyboard. I have it disconnected and a basic MS USB keyboard hooked up to play some games and the issue has totally stopped. Running iCUE version 3.15.101 which has been uninstalled multiple times with Revo, reinstalled and repaired, etc. Anyone else or does anyone know a fix? Issue started yesterday (already had 3.15.101 installed) after I added another CoPro to control more fans. Its working fine.
Link to comment
Share on other sites

Hm. It's really odd that your second Commander Pro causes this. Did you try it without your first one and just use the new one? If the issue is still there, there might be an issue with the new one.

 

If not, where are your devices' USB cables connected to? Perhaps you could try to connect one or more USB devices to an USB 3.x port at the I/O shield of the mainboard or another USB 2.0 header on the mainboard and see if that helps. If it does, then the connector(s) you're using might be overloaded due to adding the additional Commander Pro.

 

Try to connect your K95 Platinum Keyboard to a (different?) USB 3.x connector as well (perhaps one that allows you to adjust power and you could raise the power output a bit, but I'm unsure if your mainboard has such) and see if that helps.

Link to comment
Share on other sites

 Share

×
×
  • Create New...