Jump to content
Corsair Community

H150i Pro RGB - Not Showing Up In iCue


jkendt1989
 Share

Recommended Posts

I recently did a new build. My MOB is Asus Maximus XI Code with a i9-9900k.

 

iCue has worked great for everything else. Corsair PS, Corsair RGB Ram, Corsair Fans, mouse, keyboard, headset, headset stand etc...

 

I'm having issue with the H150i water cooler though.

 

When I use the standard Micro USB Cable and hook it up to the MOB pins, there's nothing. It's not detected. I've tried different USB pins, USB 3.0 pins etc... Nothing will get it to work.

 

I did however take a Mirco USB cable I had laying around and plugged it into the back of my case in a MOB USB port.

 

Bingo! Worked without any issue.

 

I do not like routing a cable outside of the case though from inside. Any idea why this would be and why the USB connectors on the MOB do not work? They work for the Corsair Fans & Corsair POS without any issue. I tried plugging the water cooler in the ones that worked for those devices and it still doesn't work.

 

Any ideas?

Link to comment
Share on other sites

 Share

×
×
  • Create New...