Jump to content
Corsair Community

ICUE showing 2 of the same device


Nemo1
 Share

Recommended Posts

Whenever I want to switch over to wireless usb it shows not connected to my mouse.when I have it connected via usb cable shows up fine then I unplugged it to wireless usb comes up as a warning. When I use it last time it works fine now it shows it own mouse any idea how to fix it? Trying to force update the firmware on the mouse. Corsair Dark Core mouse
Link to comment
Share on other sites

  • Corsair Employees

Many issues with Corsair Utility Engine can be solved by performing a clean reinstall of the software. This is a little different from just uninstalling and reinstalling the software. Please perform the steps below:

 

- Please make sure to install all updates for Windows. .

- Install RevoUninstaller: http://download.cnet.com/Revo-Uninstaller/3000-2096_4-10687648.html?part=dl-&subj=dl&tag=button

- Run RevoUninstaller

-Select iCUE, and then select uninstall

- Restart your computer

- Reinstall CUE.

 

It could also be a faulty dongle. Does it connect if you turn it off and on after unplugging it?

Link to comment
Share on other sites

Only the usb wireless that came with the mouse no longer wants to work with my mouse. I want to try to uninstall the driver for it and have my computer reinstall it back in but I don’t know how to do with out crashing my computer. I try it on my Mac same issue as well so my wireless is broken. Edited by Nemo1
Link to comment
Share on other sites

 Share

×
×
  • Create New...