Jump to content
Corsair Community

Volume button out of the blue has its own life


wim-bart
 Share

Recommended Posts

My K95 has suddenly some issues with the Volume scroll wheel, or some other issue. But the problem is that the keyboard suddenly out of nothing is starting to control the volume of my PC. Sometimes after 10 minutes sometimes direct.

 

What did I do:

  • uninstalled iCue
  • Looked for some obstruction at the wheel
  • tried other USB ports

 

But nothing seems to work. Any ideas?

Link to comment
Share on other sites

  • 3 weeks later...
  • Corsair Employees

Huh. Maybe the switch is off center or something. Try a soft reset first, if that doesn't work create a ticket.

 

We would first suggest you try a soft-reset of the keyboard. This will clear the keyboard internal memory, which often corrects issues such as the one you are experiencing. Please follow the directions below:

1: Unplug the keyboard.

2: Press the Esc key

3: While holding the Esc key, plug in the keyboard.

4: Hold the key down for 10 seconds.

5: Release the key.

Link to comment
Share on other sites

Seems to have worked and keyboard is now also recognized by iCue after every boot. And the Rainbow is back when i put on my PC (keyboard was red with white strip at top). And the Red Exclamation mark is now gone from iCue.

 

But I keep my case open and will look if it really fixed the issues.

 

Update 25-4:

As it looked like it worked, the issue is back and even worse then before. I type this on a other keyboard now because my K95 is freezing randomly now and when it does, it suddenly sends 1000nds of repeats of last keypress.

 

Maybe to look into for Corsair, can it be a Firmware issue? because the problems started after updating to v3.21.7168

Edited by wim-bart
Errors came back
Link to comment
Share on other sites

 Share

×
×
  • Create New...