Jump to content
Corsair Community

Voyager GT USB 3.0 64Gb & Windows 10


Recommended Posts

Hello.

My flash drive didn't work on my new laptop with Win10. I dug a lot and had some time with HP and Microsoft support. USB drive is not identified by Windows (Code 43). It happend with this drive on some PCs with Win10 (not all). Haven't seen such error on Win7. Of course I tried everything easy found on internet like reinstalling drivers, disabling power saving options and so on. All ports on my laptop are 3.0, but if I use USB 2.0 extension cable, drive works fine, but only with 2.0 speed of course.

After talking to HP, Microsoft and Corsair support without results and few more hours of digging internet and attempt to debug USB drivers, I found the solution or at least part of it, as I tried so many things, that I'm not sure this is only one, that helped. I added to registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\1B1C1A090000 parameter SkipBOSDescriptorQuery=1

I guess that my drive is too old (bought in October 2012), and is a bit out of USB 3.0 specs or something. It gives USBD_STATUS_BABBLE_DETECTED error, or, sometimes, USBD_STATUS_XACT_ERROR on connect.

Fixed this issue on 2 different PCs already with this method.

Hope it'll help someone else.

Can anyone tell me is it a problem of my drive firmware or something?

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 year later...
  • 7 months later...

Flash Voyager GT USB 3.0 32Gb & Windows 10

Same issue as you had.

 

I used it flawless for years.

Today I flashed MINT (UNIX OS) with balenaEtcher-Setup-1.5.120 on this stick.

And thereafter Windows 10 didn't recogonize the stick any more.

I tried GParted: format .. fat32

I copied the partition table from another voyager onto this stick (using dd command)

I reformatted the stick with GParted and MINT to FAT32

fdisk -l ..

and so on ..

Windows 7 had no problem to recognize the stick!!

At last I found your post:

As reg_binary 00 01

 

All is fine now, and a couple of hours are gone ..

Thanks a lot for your post.

You may have spent a lot more time on this issue, as I assume.

Great job!

Matthias

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...