Jump to content
Corsair Community

Mouse and Keyboard not working properly under iCue


Recommended Posts

Heyho there guys!


Finally got my K70 LUX RGB today! I'm already an owner of an Harpoon RGB but never made some spectacular lightning settings for it because my hand is always on the mouse.

But with the K70 I wanted to do some cool stuff.


So I plugged in the Keyboard (only one USB Connector) and the Keyboard started shining red, except WASD and the Arrow keys, they shined white.

Then I installed iCue and then hell opened:


The standard "Rainbow Circle" was on my keyboard and I thought "Neat!" but then I saw that my mosue lagged/stuttered. I couldn't move the mouse properly and the LED was going on and off.

Then I saw that the LEDs on the keyboard also started to lag a bit. I was pretty confused so I tried to close iCue and the Keyboard went back in its original layout. Mouse worked propley again.

Then, uninstalled iCue, checked my Chipset-Drivers, USB-Drivers and so on.

Reinstalled it, same issue. Googled and searched the forums and r/corsair and r/pcmr. Found nothing, just some tips like "update your drivers" or "check different USB Ports".

I tried every possilbe USB Port combination for those two adapters (all 3.0 ports) and neither worked. I also tried to Plug in the second USB-Adapter from the K70 but it didn't work either.


Then I found out what the switch on the back was for, tried every Polling Rate, 1, 2, 4, 8 and BIOS. When set to BIOS I can operate my mouse and Keyboard, when set to any other but BIOS, nothing works.


I'm really desperate right now and seek assistance :(

Edited by Meshi
Corrected some typos
Link to comment
Share on other sites

  • Create New...