Jump to content
Corsair Community

Commander PRO USB devices not being picked up (H150i or HX850i)


Recommended Posts



This is my first build that uses RGB but I am experiencing issues with getting the AIO & PSU to be picked up by the iCue software when their USB headers are plugged into the Commander Pro.


Motherboard: ASUS ROG STRIX X470-F

CPU: AMD Ryzen 2700X

AIO: H150i Pro RGB


RAM: Vengeance RGB PRO (2 x 8GB)

Fans: 3 x LL120 RGB + 3 x ML120

RGB Components: 6 Port Fan Hub for LLs, 1 x Commander Pro


If the USB header for the H150i Pro or the HX850i is plugged directly into the motherboard (I can't have both plugged in as there's only two slots, one taken by the Commander Pro) then the device is controllable via iCue software and provides all the relevant information.


If they are plugged into the Commander Pro USB ports then they are not controllable (nor will they show up unless previously connected into motherboard, which seems to be more of a cache thing in the app).


The RGB RAM & LL Fans work fine, and the commander pro is seen by iCue.


I have tried:

- Uninstalling / Reinstalling device drivers (including uninstalling, waiting 2 minutes after powering off etc.)

- Plugging one in at a time into the Commander Pro, in different ports

- Using the LINK software

- Firmware is up to date on all devices (confirmed in iCue), though I didn't "force" update

- Disabling USB power saver settings, as apparently ASUS motherboards can have issues where chained USBs aren't picked up properly because of that


Is there any more information I can provide? I'm sure I've missed some things that have already been attempted but after several hours trawling through the internet trying to fix it last night I can't recall it all!


Thank you

Link to comment
Share on other sites

I had the same issue with a Z370 board when I connect the CoPro directly to the USB header on the motherboard. Corsair doesn't play nice with ASMedia USB hubs. Do you have your other onboard USB header connected to you front case USB 2.0 ports? Does they work when the CoPro is connected to the other onboard header? I suspect not.


I fixed it by adding a USB hub between the motherboard's USB header and the CoPro. Originally I was using a "NZXT Internal USB Hub" but later changed it for a smaller 2 port splitter like this: USB 2.0 10-Pin Header 1-to-4 Internal USB Hub 4-Port Splitter Board (this example is 4-way but you can search eBay for something similar in the 2 port variety). Once that was done, the CoPro's USB headers worked as expected.

Edited by BlaiseP
Link to comment
Share on other sites

Unfortunately I can't check that as the ports on the front of the case use the USB 3.0 and 3.1 connectors on the motherboard, so the only thing occupying the USB 2.0 headers is currently the Commander Pro & the H150i.


I was looking into getting the NZXT USB Hub to see if that would help, but was hoping there might be another solution as it adds a bit more bulk/cables into the case (and the corsair 500D feels a bit tight for space when trying to hide everything in the back etc.!)

Link to comment
Share on other sites

Interesting. I'm having a similar problem with a Lighting Node not being picked up by a Commander Pro. When the Node is plugged directly into a mother board header it works fine. MB is a Asus Z390 Maximus XI Formula.


ETA: This issue persisted while using the default windows USB ASMedia drivers. While Asus' website does not list a different driver for my particular motherboard, I was able to find one on the mini-thumb drive that came with my MB. When I attempted to launch it using the Asus labeled setup .exe, it returned an error that the driver is not compatible with my current Windows 10 x64 installation. So I ran the non-Asus labeled setup .exe, and it installed. Now my Commander Pro will detect USB devices plugged directly into it.

Edited by bp7178
Link to comment
Share on other sites

I have replaced two Commander Pros because of USB hub issues one was through RMA the board had burnt after inspection by Corsair. The second one I just felt like the RMA process takes to long. The Two Commanders Pros that are in my system now have both quit regarding the USB Hubs and I had to move all the USB connected items off of the Commander Pros just for them to be seen. I have a NZTX internal USB hub and it works great.

In my honest opinion I do not think the Commander Pro has enough power routed via Circuit Board to maintain the USB Hub. As I have had 4 failures now with the Commander Pro where it comes to the USB Devices connect to the Hubs. So far I have had zero issues with the NZTX internal and would recommend that over the Commander Pro for USB internal connectivity. For fans and lighting the Pro is Working. Now only if Corsair can get their software to work correctly I will be able to control my fans, LEDs, and AIO.

Link to comment
Share on other sites

  • 1 year later...

I hate to revive such an old post, but I got my Pro in 2018 maybe and have the same issue. I found another threads about this, but they are from 2018-, so I will post in this one my 'workaround' (not really).


It never bothered me until I ran out of USB headers on my mobo.


Any device I connected to the USB 1 or USB 2 wouldn't be recognized. It was like they didn't exist. I tried the AIO H110, my PSU HX750i, the USB from front itself, etc and no deal.


The only thing that worked was my Fenvi Ax3000 (Wireless + Bluetooth). For the Bluetooth to work, you need to connect another USB to the mobo, since I didn't had it I sacrificed the PSU 9 pin for months now.


Today I tried again, and tested all cables in all slots. The only one that worked was the Fenvi Ax3000 cable 4 pin to 9 pin which came with the product.


I have no idea why only this cable will work. It works on both USBs from the Commander Pro. As soon as I plug it, the Windows will detect it.




The cable looks like this. Maybe it needs less power and the Commander Pro can handle it? I have no idea...


The Bluetooth is running fine, I played 1 hour straight of music from a BT speaker to test it and no issues whatsoever.

Edited by Aleczk
Link to comment
Share on other sites

  • Create New...